diff mbox series

[bug#46141] Add new shapelib

Message ID CAO+9K5oarXE3gEx3DL2izXxg8JLas7+SroOPfHGBtWoj7dW+7g@mail.gmail.com
State Accepted
Headers show
Series [bug#46141] Add new shapelib | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Jan. 27, 2021, 7:06 p.m. UTC
Hi Guix team!

This patch is a part of packaging astronomy software
https://github.com/Hellseher/guix-patches/blob/main/astronomy.org

Regards

Comments

Nicolas Goaziou Jan. 27, 2021, 8:32 p.m. UTC | #1
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/geo.scm (shapelib): New variable

I added a little Texinfo markup in description, and applied your patch.

Thank you.

Regards,
diff mbox series

Patch

From b6c776ef1ff238e8d32d94684ba36bb0bc05138d Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 27 Jan 2021 19:02:22 +0000
Subject: [PATCH] gnu: Add shapelib

* gnu/packages/geo.scm (shapelib): New variable
---
 gnu/packages/geo.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c682613ff1..942d6d1844 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2020 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1693,6 +1694,32 @@  input file (in @code{.osm} or @code{.osm.pbf} format).")
                    license:lgpl2.1+
                    license:mpl1.1))))
 
+(define-public shapelib
+  (package
+    (name "shapelib")
+    (version "1.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/OSGeo/shapelib")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1lzch0jf6yqhw391phhafzw4ghmiz98zkf698h4fmq109fa2vhqd"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (home-page "http://shapelib.maptools.org/")
+    (synopsis "Provides C library to write and update ESRI Shapefiles")
+    (description
+     "The Shapefile C Library provides the ability to write simple C programs
+for reading, writing and updating (to a limited extent) ESRI Shapefiles, and the
+associated attribute file (.dbf).")
+    (license license:gpl2+)))
+
 (define-public spatialite-tools
   (package
     (name "spatialite-tools")
-- 
2.30.0