diff mbox series

[bug#46648,1/1] gnu: Add asdf (Advanced Scientific Data Format)

Message ID CAO+9K5o06FO+OhUzf+Xw+-dh=04JJY2f+EiHqGpff=JihP5PnQ@mail.gmail.com
State Accepted
Headers show
Series [bug#46648,1/1] gnu: Add asdf (Advanced Scientific Data Format) | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Feb. 19, 2021, 10:44 p.m. UTC

Comments

Nicolas Goaziou Feb. 21, 2021, 12:09 a.m. UTC | #1
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> Subject: [PATCH] gnu: Add asdf (Advanced Scientific Data Format)

Applied. Thank you.

Regards,
diff mbox series

Patch

From c652a2585b109f6bde9d801ccb70835ef6935c7b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 19 Feb 2021 22:41:42 +0000
Subject: [PATCH] gnu: Add asdf (Advanced Scientific Data Format)

* gnu/packages/astronomy.scm (python-asdf): New variable
---
 gnu/packages/astronomy.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d1022ee5da..38f76b7c81 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -948,6 +948,38 @@  of stand-alone functions and classes.")
                    license:expat
                    license:lgpl3+))))
 
+(define-public python-asdf
+  (package
+    (name "python-asdf")
+    (version "2.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "asdf" version))
+       (sha256
+        (base32 "1y47zhkd90i8wmm2i35amfl0rvjqlb3fcx90xp7n9kr2z0byzyzg"))))
+    (build-system python-build-system)
+    (arguments
+     ;; TODO: (Sharlatan-20210207T165820+0000): Tests depend on astropy, astropy
+     ;; depends on asdf. Disable circular dependence.
+     `(#:tests? #f))
+    (native-inputs
+     `(("setuptools-scm" ,python-setuptools-scm)
+       ("semantic-version" ,python-semantic-version)
+       ("packaging" ,python-packaging)))
+     (inputs
+      `(("importlib-resources" ,python-importlib-resources)
+        ("jsonschema" ,python-jsonschema)
+        ("numpy" ,python-numpy)
+        ("pyyaml" ,python-pyyaml)))
+     (home-page "http://github.com/asdf-format/asdf")
+     (synopsis "Python tools to handle ASDF files")
+     (description
+      "The Advanced Scientific Data Format (ASDF) is a next-generation
+interchange format for scientific data.  This package contains the Python
+implementation of the ASDF Standard.")
+     (license license:bsd-3)))
+
 (define-public python-astroalign
   (package
     (name "python-astroalign")
-- 
2.30.0