diff mbox series

[bug#50324] gnu: Add python-dotenv.

Message ID CANNGBfnfBfU3BWPBv5+uTE5F2JNr=F5EUM=NhZjmDDCjF6RAGQ@mail.gmail.com
State New
Headers show
Series [bug#50324] gnu: Add python-dotenv. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zac Berkowitz Sept. 1, 2021, 3:39 p.m. UTC
* gnu/packages/python-xyz.scm (python-dotenv): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

following the
+@url{http://12factor.net,12-factor} principles.")
+    (license license:bsd-3)))
--
2.33.0

Comments

jgart Sept. 2, 2021, 2:06 p.m. UTC | #1
Hi,

There is a patch open already for python-dotenv as part of this issue: http://issues.guix.gnu.org/50213#28

It is part of upgrading flask to 2.0.1

Maybe we can commit together if there is anything you would like to merge with the patch you just sent?

all best,

jgart
 
 _________________________________________ 
/ 3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 \
\ 77B6 DD35                               /
 ----------------------------------------- 
        \   ^__^
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||
Sarah Morgensen Sept. 3, 2021, 12:50 a.m. UTC | #2
jgart <jgart@dismail.de> writes:

> There is a patch open already for python-dotenv as part of this issue: http://issues.guix.gnu.org/50213#28

There is also one at #49834 [0], so that makes three :)

[0] https://issues.guix.gnu.org/49834#13

--
Sarah
jgart Sept. 3, 2021, 1:48 a.m. UTC | #3
On Thu, 02 Sep 2021 17:50:31 -0700 Sarah Morgensen <iskarian@mgsn.dev> wrote:
> 
> jgart <jgart@dismail.de> writes:
> 
> > There is a patch open already for python-dotenv as part of this issue: http://issues.guix.gnu.org/50213#28
> 
> There is also one at #49834 [0], so that makes three :)

Hahahaha dotenv is in high demand!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d1a679133..c06a32d027 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26435,3 +26435,31 @@  a (rather superficial) static analysis, and
constructs a directed graph of the
 objects in the combined source, and how they define or use each other.  The
 graph can be output for rendering by GraphViz or yEd.")
     (license license:gpl2)))
+
+(define-public python-dotenv
+  (package
+    (name "python-dotenv")
+    (version "0.19.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-dotenv" version))
+       (sha256
+        (base32
+         "0wk1kfzbpqk9swvmpa9z3q170ffqql2id4b2dxrkrq58r4mbq8gm"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-mock" ,python-mock)
+       ("python-sh" ,python-sh)))
+    (propagated-inputs
+     `(("python-click" ,python-click)))
+    (home-page
+     "https://saurabh-kumar.com/python-dotenv/")
+    (synopsis
+     "Read key-value pairs from a .env file and set them as
environment variables")
+    (description
+     "Python-dotenv reads key-value pairs from a .env file and can set them as
+environment variables.  It helps in the development of applications