[bug#75447] adding guile-uuid package
Commit Message
Hi all,
I am adding a package definition for a really cool package, guile-uuid.
Hope I didn't miss anything,
Regards,
Joe
From 111801a8a6b6d0e3971e6ff89f99f50e397c1337 Mon Sep 17 00:00:00 2001
Message-ID: <111801a8a6b6d0e3971e6ff89f99f50e397c1337.1736350673.git.jjbigorra@gmail.com>
From: Josep Bigorra <jjbigorra@gmail.com>
Date: Wed, 8 Jan 2025 16:37:35 +0100
Subject: [PATCH] added guile-uuid package
---
gnu/packages/guile-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
@@ -347,6 +347,34 @@ (define-public guile-openai
models.")
(license license:agpl3+))))
+;; There are no releases yet of this package.
+(define-public guile-uuid
+ (let ((commit "64002d74025f577e1eeea7bc51218a2c7929631f")
+ (revision "0"))
+ (package
+ (name "guile-uuid")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/elb/guile-uuid.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q6dqm2hzq75aa5mrrwgqdml864pdrxc98j7pyj1y0827phnzjfj"))))
+ (build-system guile-build-system)
+ (native-inputs (list guile-3.0 guile-gcrypt))
+ (home-page "https://codeberg.org/elb/guile-uuid")
+ (synopsis
+ "Guile-UUID is a UUID generation and manipulation module for GNU Guile.")
+ (description
+ "This package implements RFC 9562 UUIDs, and can generate versions 1 and 3–8 from that specification.
+ It provides parsing for UUIDs in standard hex-and-dash format of any variant and version.
+ It can also query the variant and version of UUIDs from the RFC.
+ Simple routines for converting between binary and hex-and-dash string UUIDs are included.")
+ (license license:gpl3+))))
+
;; There are no releases yet of this package.
(define-public guile-pipe
(let ((commit "0746ec38d19d844dff0c6f62f209b2b6c8d8872e")
--
2.46.0