diff mbox series

[bug#38659] Fix FreeCAD dependencies.

Message ID CAKf5CqXtjpwHF7+wcSCmv75PJ4qMgFn5zsL2auiqMO2r5ej36w@mail.gmail.com
State Accepted
Headers show
Series [bug#38659] Fix FreeCAD dependencies. | expand

Commit Message

John Soo Dec. 18, 2019, 2:24 p.m. UTC
Hi all,

Since the addition of clang-toolchain, python-shiboken-2 and
python-pyside-2 have had failing builds.  This patchset updates them to use
clang-toolchain.

- John

Comments

Efraim Flashner Dec. 19, 2019, 8:38 a.m. UTC | #1
Thanks. I adjusted the commit message slightly.
diff mbox series

Patch

From 12a0469ca8c3f30426c709872562922cc3e0237b Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Wed, 18 Dec 2019 06:21:00 -0800
Subject: [PATCH 1/2] gnu: Fix python-shiboken-2.

* gnu/packages/qt.scm (python-shiboken-2): Update inputs.
---
 gnu/packages/qt.scm | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c0d652a407..747d5437e2 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2107,8 +2107,7 @@  color-related widgets.")
            "0g8jacm2iqd7lw2m7f1dp1nnrsk38bl3m8pihm8zz9gxs8d31sf5"))))
       (build-system cmake-build-system)
       (inputs
-       `(("llvm-6" ,llvm-6)
-         ("clang-6" ,clang-6)
+       `(("clang-toolchain" ,clang-toolchain-6)
          ("libxml2" ,libxml2)
          ("libxslt" ,libxslt)
          ("python-wrapper" ,python-wrapper)
@@ -2124,7 +2123,7 @@  color-related widgets.")
              (lambda _ (chdir "sources/shiboken2") #t))
            (add-before 'configure 'set-build-env
              (lambda* (#:key inputs #:allow-other-keys)
-               (let ((llvm (assoc-ref inputs "llvm-6")))
+               (let ((llvm (assoc-ref inputs "clang-toolchain")))
                  (setenv "CLANG_INSTALL_DIR" llvm)
                  #t))))))
       (home-page "https://wiki.qt.io/Qt_for_Python")
-- 
2.24.0