diff mbox series

[bug#38640] Add ripgrep and many rust dependencies

Message ID CAKf5CqXNnZAt6dHrFeWKa92tCA8746mnCo8S352VBMYeBrLKZw@mail.gmail.com
State Accepted
Headers show
Series [bug#38640] Add ripgrep and many rust dependencies | expand

Commit Message

John Soo Dec. 20, 2019, 5:44 p.m. UTC
Hi all,

Sorry it took a while. As it turns out, keeping #cargo-inputs and
#cargo-development-inputs was a very good idea.
It turns out I was missing about 60 more dependencies! I linted them
as far as I could without breaking anything.
I added #skip-build #t to all the other dependencies.

The only issue here is that the commit order has somewhat lost the
topological order of the dependencies because rebasing them all
required too much conflict resolution.

I rebased these on master this morning.

Thanks for all your input!

John

Comments

John Soo Dec. 21, 2019, 4:18 a.m. UTC | #1
Oh I found out that rust-serde-test-1.0 had a hash mismatch. Here is the
fix.
Efraim Flashner Dec. 31, 2019, 8:57 a.m. UTC | #2
This is a lot of patches, so I wanted to give a heads up that I'm
working on them currently.

On Sat, Dec 21, 2019 at 04:18:28AM +0000, John Soo wrote:
> Oh I found out that rust-serde-test-1.0 had a hash mismatch. Here is the
> fix.
John Soo Dec. 31, 2019, 3:49 p.m. UTC | #3
Thanks for the heads up, Efraim!

On Tue, Dec 31, 2019 at 8:57 AM Efraim Flashner <efraim@flashner.co.il> wrote:
>
> This is a lot of patches, so I wanted to give a heads up that I'm
> working on them currently.

Thank you for working on them.

- John
Efraim Flashner Jan. 2, 2020, 6:20 p.m. UTC | #4
Patches pushed. I added about another 30 to the set.
diff mbox series

Patch

From ca7ea6137ef582cf74f5ea300200fb7e8544031e Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sun, 15 Dec 2019 11:27:39 -0800
Subject: [PATCH 263/263] gnu: Add ripgrep.

* gnu/packages/rust-apps.scm (ripgrep): New variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk               |  1 +
 gnu/packages/rust-apps.scm | 73 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 74 insertions(+)
 create mode 100644 gnu/packages/rust-apps.scm

diff --git a/gnu/local.mk b/gnu/local.mk
index 5cb96cc354..b8f5afd69d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -433,6 +433,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/ruby.scm				\
   %D%/packages/rush.scm				\
   %D%/packages/rust.scm				\
+  %D%/packages/rust-apps.scm			\
   %D%/packages/rust-cbindgen.scm		\
   %D%/packages/samba.scm			\
   %D%/packages/sagemath.scm			\
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
new file mode 100644
index 0000000000..e48b933384
--- /dev/null
+++ b/gnu/packages/rust-apps.scm
@@ -0,0 +1,73 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rust-apps)
+  #:use-module (gnu packages crates-io)
+  #:use-module (guix build-system cargo)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages))
+
+(define-public ripgrep
+  (package
+    (name "ripgrep")
+    (version "11.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ripgrep" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0bn40lz9n08llq615p4qqqbi24zbkf0appfx3zgxg34a86ga9zds"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-bitflags" ,rust-bitflags-1)
+        ("rust-bstr" ,rust-bstr-0.1)
+        ("rust-grep" ,rust-grep-0.2)
+        ("rust-ignore" ,rust-ignore-0.4)
+        ("rust-itoa" ,rust-itoa-0.4)
+        ("rust-num-cpus" ,rust-num-cpus-1.10)
+        ("rust-proc-macro2" ,rust-proc-macro2-1.0)
+        ("rust-quote" ,rust-quote-1.0)
+        ("rust-ryu" ,rust-ryu-1.0)
+        ("rust-strsim" ,rust-strsim-0.8)
+        ("rust-syn" ,rust-syn-1.0)
+        ("rust-textwrap" ,rust-textwrap-0.11)
+        ("rust-ucd-util" ,rust-ucd-util-0.1)
+        ("rust-unicode-width" ,rust-unicode-width-0.1)
+        ("rust-unicode-xid" ,rust-unicode-xid-0.2)
+        ("rust-winapi" ,rust-winapi-0.3)
+        ("rust-wincolor" ,rust-wincolor-1.0))
+       #:cargo-development-inputs
+       (("rust-clap" ,rust-clap-2)
+        ("rust-lazy-static" ,rust-lazy-static-1.3)
+        ("rust-serde" ,rust-serde-1.0)
+        ("rust-serde-derive" ,rust-serde-derive-1.0))))
+    (home-page
+     "https://github.com/BurntSushi/ripgrep")
+    (synopsis
+     "Line-oriented search tool")
+    (description
+     "ripgrep is a line-oriented search tool that recursively searches
+your current directory for a regex pattern while respecting your
+gitignore rules.  ripgrep has first class support on Windows, macOS
+and Linux.")
+    (license `(,license:unlicense ,license:expat))))
-- 
2.24.1