From 9524b60aa99a0d1ca88d4ed2c8b54354942956fc Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Fri, 13 Dec 2019 09:21:50 -0800
Subject: [PATCH 22/22] gnu: Add purescript.
* gnu/packages/purescript.scm (purescript): New variable.
---
gnu/local.mk | 2 +-
gnu/packages/purescript.scm | 89 +++++++++++++++++++++++++++++++++++++
2 files changed, 90 insertions(+), 1 deletion(-)
@@ -405,7 +405,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/pretty-print.scm \
%D%/packages/protobuf.scm \
%D%/packages/pure.scm \
- %D$/packages/purescript.scm \
+ %D%/packages/purescript.scm \
%D%/packages/pv.scm \
%D%/packages/python.scm \
%D%/packages/python-check.scm \
@@ -116,3 +116,92 @@
(sha256
(base32
"1xacvl5wf47cz61igb94zf961b9ks0yhr02myxgjf53clm70dg6j"))))))
+
+(define-public purescript
+ (package
+ (name "purescript")
+ (version "0.13.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/purescript/purescript-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0plqzlcfaw2ik2im7aq8yy1b1y88cnc8qd7wwaayndbdz060s9j4"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-glob" ,ghc-glob-0.9.3)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-aeson-better-errors" ,ghc-aeson-better-errors)
+ ("ghc-aeson-pretty" ,ghc-aeson-pretty)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal-0.8.2)
+ ("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-bower-json" ,ghc-bower-json)
+ ("ghc-boxes" ,ghc-boxes)
+ ("ghc-cheapskate" ,ghc-cheapskate)
+ ("ghc-clock" ,ghc-clock-0.7.2)
+ ("ghc-cryptonite" ,ghc-cryptonite)
+ ("ghc-data-ordlist" ,ghc-data-ordlist)
+ ("ghc-dlist" ,ghc-dlist)
+ ("ghc-edit-distance" ,ghc-edit-distance)
+ ("ghc-file-embed" ,ghc-file-embed)
+ ("ghc-fsnotify" ,ghc-fsnotify)
+ ("ghc-happy" ,ghc-happy)
+ ("ghc-language-javascript" ,ghc-language-javascript)
+ ("ghc-lifted-async" ,ghc-lifted-async-0.10.0.4)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-memory" ,ghc-memory)
+ ("ghc-microlens-platform" ,ghc-microlens-platform)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-monad-logger" ,ghc-monad-logger)
+ ("ghc-network" ,ghc-network-3.0.1.1)
+ ("ghc-parallel" ,ghc-parallel)
+ ("ghc-pattern-arrows" ,ghc-pattern-arrows)
+ ("ghc-protolude" ,ghc-protolude)
+ ("ghc-regex-tdfa" ,ghc-regex-tdfa)
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-semialign" ,ghc-semialign)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-sourcemap" ,ghc-sourcemap)
+ ("ghc-split" ,ghc-split)
+ ("ghc-stringsearch" ,ghc-stringsearch)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-these" ,ghc-these)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-network" ,ghc-network)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-wai-websockets" ,ghc-wai-websockets)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-websockets" ,ghc-websockets)
+ ("ghc-gitrev" ,ghc-gitrev)))
+ (native-inputs
+ `(("ghc-happy" ,ghc-happy-1.19.9)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hspec" ,ghc-tasty-hspec)))
+ (arguments
+ `(;; Tests require npm
+ #:tests? #f
+ ;; Haddock fails
+ #:haddock? #f
+ #:configure-flags '("--flags=release")))
+ (home-page "http://www.purescript.org/")
+ (synopsis "Haskell inspired programming language compiling to JavaScript")
+ (description
+ "A small strongly, statically typed programming language with
+expressive types, inspired by Haskell and compiling to JavaScript.")
+ (license license:bsd-3)))
--
2.24.0