diff mbox series

[bug#36440] Add FreeCAD

Message ID CAKf5CqX7tWstw8WW3JcnxLhQhDhkh4BS=ToMG_qPozH=LDhQ9g@mail.gmail.com
State Accepted
Headers show
Series [bug#36440] Add FreeCAD | expand

Commit Message

John Soo Sept. 11, 2019, 2:19 p.m. UTC
Hi all,

I rebased the patches on master. Thanks again!

- John

Comments

Björn Höfling Sept. 22, 2019, 7:09 a.m. UTC | #1
On Wed, 11 Sep 2019 14:19:19 +0000
John Soo <jsoo1@asu.edu> wrote:

> Hi all,
> 
> I rebased the patches on master. Thanks again!
> 
> - John

Hi John,

thanks for the efford you put into FreeCAD.

I pushed this as:

4cd9de6068f439c52f6874f00ec608c41156d095

with these changes:

I dropped the "llvm-toolchain-6" package, which is just a union-package
and instead used llvm-6 and clang-6 as inputs (Thanks to Ludo for
pointing at this).

libcxx-6: Left the description as inherited, added the speciality for
pyside2 as a comment.

libspnav: The linter had an issue with the sourceforge-sources? Then I
went directly to the github sources via git-fetch.

FreeCAD: Commented out the dependency on qtwebkit: It takes soo long to
compile and substitutes are rarely available.

Double-Checked licenses and fixed the ;;Help-comments on licenses field.

Björn
John Soo Sept. 22, 2019, 4 p.m. UTC | #2
Hi Bjorn!

Thank you so much!  Whew what a journey.

I am glad that the union package of llvm and clang could be separated. When
I was working on the package in the very beginning pyside2 would not build
without clang and llvm living in the same parent directory.

I did just run the program and it does not look like it is functioning the
way it should. With the last patchset I submitted, it did work properly. I
will investigate...

Thanks again, it's been a real pleasure working with you.

- John
Björn Höfling Sept. 22, 2019, 5:50 p.m. UTC | #3
Hi John,

On Sun, 22 Sep 2019 16:00:36 +0000
John Soo <jsoo1@asu.edu> wrote:

> Thank you so much!  Whew what a journey.

I'm glad you went through that :-) I also wanted to do it in the first
place but then gave up because it was a bit hard and I had no longer
the priority to do so.

> I did just run the program and it does not look like it is
> functioning the way it should. With the last patchset I submitted, it
> did work properly. I will investigate...

what is not functioning at your side?

I started the program and it works for me (though I'm not yet familiar
with it, so I cannot say how exactly it SHOULD work :-)), otherwise I
wouldn't have pushed it.

What I can see is a red text on the Console:

No module named 'WebGui'

But that's of cause because I commented out the webkit. I still hope
this is more-or-less fine, otherwise we need to turn that on again.

What I noticed is that the binary is called "FreeCAD" and not
"freecad", that confused me first. I think that can be fixed with some
phase, but I couldn't quickly figure that out and I really didn't want
to postpone this any more.

Otherwise the first screen looks quite blank. But that's just a matter
of going through the menus:

View->Workbench->Part, etc. In that way, I was able to construct a
cylinder. Now I can no longer, but I think that's just because I forget
how to do it and I have to go through the tutorial again.

I also saw that Cuirass did not build it for x86 due to a dependency
problem, without saying what exactly went wrong:

https://ci.guix.gnu.org/build/1739605/details
https://ci.guix.gnu.org/build/1739601/details

For non-x86 it is even worse, some tests failed for some dependencies.
 
> Thanks again, it's been a real pleasure working with you.

Same for me.

Björn
diff mbox series

Patch

From ec65b56e11590682beaa94a66037a46308372002 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sun, 7 Jul 2019 10:13:17 -0700
Subject: [PATCH 09/10] gnu: Add libmedfile.

* gnu/packages/engineering.scm (libmedfile): New variable.
---
 gnu/packages/engineering.scm | 45 ++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f238b0cc98..b02ce623af 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2217,6 +2217,51 @@  full programmatic control over your models.")
     (home-page "https://www.openscad.org/")
     (license license:gpl2+)))
 
+(define-public libmedfile
+  (package
+    (name "libmedfile")
+    (version "4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://files.salome-platform.org/Salome/other/med-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "017h9p0x533fm4gn6pwc8kmp72rvqmcn6vznx72nkkl2b05yjx54"))))
+    (build-system cmake-build-system)
+    (inputs `(("hdf5" ,hdf5-1.10)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'remove-test-output
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (delete-file-recursively
+                (string-append out "/bin/testc"))
+               #t))))))
+    (home-page "https://www.salome-platform.org")
+    (synopsis "Library to read and write MED files")
+    (description
+     "The purpose of the MED module is to provide a standard for storing and
+recovering computer data associated to numerical meshes and fields, and to
+facilitate the exchange between codes and solvers.
+
+The persistent data storage is based upon HDF format (like CGNS, a standard
+developed by Boeing and NASA in the area of Computational Fluid Dynamic).
+
+MED also provides structures to hold data on meshes and fields. These
+structures are exchanged between solvers, hide the communication level (CORBA
+or MPI), and offer persistence (read/write in .med files).
+
+The main benefit of a common exchange format is reduced complexity of code
+coupling. It also allows sharing such high level functionalities as
+computation of nodal connectivity of sub-elements (faces and edges),
+arithmetic operations on fields, entity location functionalities, and
+interpolation toolkit.")
+    (license license:gpl3+)))
+
 (define-public libarea
   (let ((revision "1")
         (commit "8f8bac811c10f1f01fda0d742a18591f61dd76ee"))
-- 
2.23.0