diff mbox series

[bug#39159] Add Tokei

Message ID CAKf5CqWzthhXFuMdiD0eFp=H1HJxO32cJRdXDzQSsJS3ww657g@mail.gmail.com
State Accepted
Headers show
Series [bug#39159] Add Tokei | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

John Soo Jan. 17, 2020, 5:30 a.m. UTC
Hi Guix!

Tokei is a very fast source code counting command line interface.

It is written in rust, explaining the large number of patches.

I linted these and rebased on master this evening.

Thanks,

John
diff mbox series

Patch

From d65e490dfd6e305ce6c7373ad88fe68e5bba75c1 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Wed, 15 Jan 2020 10:02:38 -0800
Subject: [PATCH 70/70] gnu: Add tokei.

* gnu/packages/crates-io.scm (tokei): New variable.
---
 gnu/packages/rust-apps.scm | 52 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index fa1f56e96f..a959e46967 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -92,3 +92,55 @@  gitignore rules.")
     (description
      "This package provides a tool for generating C/C++ bindings to Rust code.")
     (license license:mpl2.0)))
+
+(define-public tokei
+  (package
+    (name "tokei")
+    (version "10.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "tokei" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "07f5laqw2k9l3k8wrg9h8p2m5d9hkfxngyacwrn3vs7mlnw8l81m"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+        (("rust-cc" ,rust-cc-1.0)
+         ("rust-clap" ,rust-clap-2)
+         ("rust-crossbeam-channel" ,rust-crossbeam-channel-0.4)
+         ("rust-dirs" ,rust-dirs-2.0)
+         ("rust-encoding-rs-io" ,rust-encoding-rs-io-0.1)
+         ("rust-env-logger" ,rust-env-logger-0.7)
+         ("rust-grep-searcher" ,rust-grep-searcher-0.1)
+         ("rust-hex" ,rust-hex-0.4)
+         ("rust-ignore" ,rust-ignore-0.4)
+         ("rust-log" ,rust-log-0.4)
+         ("rust-pkg-config" ,rust-pkg-config-0.3)
+         ("rust-rayon" ,rust-rayon-1.3)
+         ("rust-serde" ,rust-serde-1.0)
+         ("rust-serde-cbor" ,rust-serde-cbor-0.10)
+         ("rust-serde-derive" ,rust-serde-derive-1.0)
+         ("rust-serde-json" ,rust-serde-json-1.0)
+         ("rust-serde-yaml" ,rust-serde-yaml-0.8)
+         ("rust-term-size" ,rust-term-size-0.3)
+         ("rust-toml" ,rust-toml-0.5)
+         ("rust-vcpkg" ,rust-vcpkg-0.2))
+        #:cargo-development-inputs
+        (("rust-git2" ,rust-git2-0.11)
+         ("rust-handlebars" ,rust-handlebars-2.0)
+         ("rust-ignore" ,rust-ignore-0.4)
+         ("rust-lazy-static" ,rust-lazy-static-1.4)
+         ("rust-regex" ,rust-regex-1.3)
+         ("rust-serde-json" ,rust-serde-json-1.0)
+         ("rust-tempfile" ,rust-tempfile-3.0))))
+    (home-page "https://tokei.rs")
+    (synopsis
+      "Count code, quickly")
+    (description
+      "This package provides a utility that allows you to count code,
+quickly.")
+    (license (list license:expat license:asl2.0))))
-- 
2.24.1