diff mbox series

[bug#36545] Add Hoogle

Message ID CAKf5CqVrVUN8pvKKZ+zx5KgYiHSc-mErcVMX-khyoyEmOaR7KA@mail.gmail.com
State Accepted
Headers show
Series [bug#36545] Add Hoogle | expand

Commit Message

John Soo Aug. 15, 2019, 5:09 p.m. UTC
Hi Robert,

Thank you for your patience.

> - ghc-mtl shouldn’t be packaged, as it’s a GHC-bundled library.

I removed all references to ghc-mtl

> - Is there a particular reason that tests are disabled?

I had removed them for expedience but I have added them back. There is
one exception whose tests do network IO, so I added a comment there.

I rebased the patches on current master a few minutes ago.  Thanks again!

- John
diff mbox series

Patch

From 82cc15f8a9bc623102b2ca04aa3dfb4c6334945f Mon Sep 17 00:00:00 2001
From: John Soo <jsoo@panosoft.com>
Date: Sun, 7 Jul 2019 18:03:26 -0700
Subject: [PATCH 12/12] gnu: Add hoogle.

* gnu/packages/haskell-apps.scm (hoogle): New variable.
---
 gnu/packages/haskell-apps.scm | 53 +++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index e77f6d113b..578dbaf2c3 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
 ;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -405,3 +406,55 @@  play inspired from classics Lemmings and The Incredible Machine.  The project
 proved to be an excellent learning experience for the programmers.  Everything
 is programmed in Haskell.")
     (license license:bsd-3)))
+
+(define-public hoogle
+  (package
+    (name "hoogle")
+    (version "5.0.17.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "https://hackage.haskell.org/package/hoogle/hoogle-"
+         version ".tar.gz"))
+       (sha256
+        (base32
+         "174gp41v0krzj37m75pnr3aawyhkbk2wq4q6zk2z3zh0avvvmgk6"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-network-uri" ,ghc-network-uri)
+       ("ghc-network" ,ghc-network)
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-aeson" ,ghc-aeson)
+       ("ghc-cmdargs" ,ghc-cmdargs)
+       ("ghc-conduit" ,ghc-conduit)
+       ("ghc-conduit-extra" ,ghc-conduit-extra)
+       ("ghc-connection" ,ghc-connection)
+       ("ghc-extra" ,ghc-extra)
+       ("ghc-old-locale" ,ghc-old-locale)
+       ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
+       ("ghc-http-conduit" ,ghc-http-conduit)
+       ("ghc-http-types" ,ghc-http-types)
+       ("ghc-js-flot" ,ghc-js-flot)
+       ("ghc-js-jquery" ,ghc-js-jquery)
+       ("ghc-mmap" ,ghc-mmap)
+       ("ghc-process-extras" ,ghc-process-extras)
+       ("ghc-resourcet" ,ghc-resourcet)
+       ("ghc-storable-tuple" ,ghc-storable-tuple)
+       ("ghc-tar" ,ghc-tar)
+       ("ghc-uniplate" ,ghc-uniplate)
+       ("ghc-utf8-string" ,ghc-utf8-string)
+       ("ghc-vector" ,ghc-vector)
+       ("ghc-wai" ,ghc-wai)
+       ("ghc-wai-logger" ,ghc-wai-logger)
+       ("ghc-warp" ,ghc-warp)
+       ("ghc-warp-tls" ,ghc-warp-tls)
+       ("ghc-zlib" ,ghc-zlib)))
+    (home-page "https://hoogle.haskell.org/")
+    (synopsis "Haskell API Search")
+    (description
+     "Hoogle is a Haskell API search engine, which allows you to search many
+standard Haskell libraries by either function name, or by approximate type
+signature.")
+    (license license:bsd-3)))
-- 
2.22.0