diff mbox series

[bug#39488] gnu: add fd.

Message ID CAKf5CqVPS+_mtKTp4i7QH2pnBk31xnvSSHngfZqzYGwe3Z76UA@mail.gmail.com
State Accepted
Headers show
Series [bug#39488] gnu: add fd. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

John Soo Feb. 7, 2020, 5:27 p.m. UTC
Hi Guix,

fd is a fast program like find written in rust.

Thanks,

John

Comments

Efraim Flashner Feb. 8, 2020, 7:05 p.m. UTC | #1
A couple of notes:

rust-nix-0.14: rust-sysctl should be 0.1, not 0.4. I added 0.1 and
switched the dependency.

rust-ctrlc-3.1: It builds with no problems so I removed skip-build

rust-lscolors-0.6: rust-ansi-term should be 0.12, not 0.11. I changed it
and removed skip-build.

fd: rust-clap is a dependency and build dependency and version-check a
build-dependency so I put them in cargo-dependencies. I flushed out the
description a bit. I checked the cargo.toml and I wasn't sure if
jemalloc was used or not (it looked like not windows or not musl) but I
see it building jemalloc-sys so I see it is. fd.bash should be renamed
to just 'fd' so I added a rename-file after the installation. As a last
thing I changed the jemalloc reference to jemalloc.so and now 'guix gc
--references' retains a reference to jemalloc.
diff mbox series

Patch

From 43a155c8703f32c9b3e9c4d61d1400074245446f Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 21 Jan 2020 09:28:49 -0800
Subject: [PATCH 3/5] gnu: Add rust-lscolors-0.6.

* gnu/packages/crates-io.scm (rust-lscolors-0.6): New variable.
---
 gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cd729f6a2b..386bf84b8f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6881,6 +6881,33 @@  pairs in insertion order.")
         ("rust-serde" ,rust-serde-0.8)
         ("rust-serde-test" ,rust-serde-test-0.8))))))
 
+(define-public rust-lscolors-0.6
+  (package
+    (name "rust-lscolors")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "lscolors" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0jxsgkn378kxkiqdshdjdclw5wwp2xaz45cqd3yw85fhn8a38fza"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-ansi-term" ,rust-ansi-term-0.11))
+       #:cargo-development-inputs
+       (("rust-tempfile" ,rust-tempfile-3.1))))
+    (home-page "https://github.com/sharkdp/lscolors")
+    (synopsis
+     "Colorize paths using the LS_COLORS environment variable")
+    (description
+     "Colorize paths using the LS_COLORS environment variable.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-new-debug-unreachable-1.0
   (package
     (name "rust-new-debug-unreachable")
-- 
2.25.0