diff mbox series

[bug#39758] Add qtbase-patched. (Fix QTBUG-81715)

Message ID CAKf5CqV-R5atuN58O_R+Jt2WK0JwSbY9cYPc=39u2VG8iYfccQ@mail.gmail.com
State Accepted
Headers show
Series [bug#39758] Add qtbase-patched. (Fix QTBUG-81715) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

John Soo Feb. 23, 2020, 5:41 p.m. UTC
Hi Guix,

There is a known issue in qtbase 5.12.7 where the cmake macros shipped
with qt do not work when paths include dots.  This broke freecad and
maybe others.

I am not sure how to figure out other broken packages, if they need to
use the patched-qtbase.

Thanks,

John

Comments

Marius Bakke Feb. 24, 2020, 5:16 p.m. UTC | #1
John Soo <jsoo1@asu.edu> writes:

> Hi Guix,
>
> There is a known issue in qtbase 5.12.7 where the cmake macros shipped
> with qt do not work when paths include dots.  This broke freecad and
> maybe others.

Thanks!  I've pushed the patches with a few modifications in
e2546bb472b6285a8856cacf686c5e0ce9bb62c5 and
3c60d85f313f910282ed884eead80061faf6ee78.

I will move the patch to the regular qtbase package on the 'staging'
branch later to avoid the custom variant.

> I am not sure how to figure out other broken packages, if they need to
> use the patched-qtbase.

Typically you'd have to do 'guix refresh -l qtbase' and copy-paste the
package list to a 'guix build' invokation.  IWBN to have a single
command for that.

[...]
  
> From 92ba3b59a2ff1dd6b4078c649a468fa208b47a59 Mon Sep 17 00:00:00 2001
> From: John Soo <jsoo1@asu.edu>
> Date: Fri, 21 Feb 2020 21:14:57 -0800
> Subject: [PATCH 3/4] gnu: freecad. Fix build failures.
>
> * gnu/packages/engineering.scm (freecad): [supported-systems] Only support aarch64 and
> x86_64-linux, [inputs] use qtbase-patched instead of qtbase.

I dropped the [supported-systems] change as it seems unrelated to the
qtbase problem.  Could you submit it as a separate patch, ideally with a
comment that explains why we do it (i.e. "upstream only supports
64-bit platforms")?
diff mbox series

Patch

From c489352465aa93746f7a48e06c8481093894f1a3 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Fri, 21 Feb 2020 21:15:38 -0800
Subject: [PATCH 4/4] gnu: freecad. Use qt-build-system.

* gnu/packages/engineering.scm (freecad): [build-system] Use qt-build-system.
---
 gnu/packages/engineering.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index e84e7a87e9..c1078e2245 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -44,6 +44,7 @@ 
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
@@ -2267,7 +2268,7 @@  full programmatic control over your models.")
        (sha256
         (base32
          "170hk1kgrvsddrwykp24wyj0cha78zzmzbf50gn98x7ngqqs395s"))))
-    (build-system cmake-build-system)
+    (build-system qt-build-system)
     (native-inputs
      `(("doxygen" ,doxygen)
        ("graphviz" ,graphviz)
-- 
2.25.1