diff mbox series

[bug#38596] Add PureScript

Message ID CAKf5CqUkZ7EdPuYPQgpwj7NCS5PFxVLuH=Sfv5ytthMt3wykLw@mail.gmail.com
State Accepted
Headers show
Series [bug#38596] Add PureScript | expand

Commit Message

John Soo Dec. 13, 2019, 6:46 p.m. UTC
Hi Guix,

Here are my patches for PureScript, a haskell inspired language that
compiles to JavaScript.

I took all dependencies with the exception of one from stackage lts14.

The exception is language-javascript. What do I do about that?

There were a few more dependencies that are not in the stackage lts, but I
did not make them publically available and placed them in purescript.scm.

I did a lint and fixed most of the errors I could and built with --rounds=2
--check.

Thanks!

John
diff mbox series

Patch

From ad769be9b6c0aba12bff28d5d41bb3333414b146 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Fri, 13 Dec 2019 08:56:13 -0800
Subject: [PATCH 21/22] gnu: Add ghc-network@3.0.1.1

* gnu/packages/purescript.scm (ghc-network-3.0.1.1): New variable.
---
 gnu/packages/purescript.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

diff --git a/gnu/packages/purescript.scm b/gnu/packages/purescript.scm
index 10e69151df..8936e1bb87 100644
--- a/gnu/packages/purescript.scm
+++ b/gnu/packages/purescript.scm
@@ -101,3 +101,18 @@ 
        (sha256
         (base32
          "0cwl1d0wjpdk0v1l1qxiqiksmak950c8gx169c1q77cg0z18ijf9"))))))
+
+(define ghc-network-3.0.1.1
+  (package
+    (inherit ghc-network)
+    (version "3.0.1.1")
+    (source
+     (origin
+       (inherit (package-source ghc-network))
+       (uri (string-append
+             "mirror://hackage/package/network/network-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1xacvl5wf47cz61igb94zf961b9ks0yhr02myxgjf53clm70dg6j"))))))
-- 
2.24.0