diff mbox series

[bug#36545] Add Hoogle

Message ID CAKf5CqU_iLhFnKj4f7Sd6f4dMF5H8QGVpbD1szXOzhcgDJHPqQ@mail.gmail.com
State Accepted
Headers show
Series [bug#36545] Add Hoogle | expand

Commit Message

John Soo Aug. 16, 2019, 5:58 a.m. UTC
Hi Robert and Guix,

I realized just now that I had some incorrect git configuration. I have
attached the updated patches with my correct email address.

Thanks again!

- John

Comments

Robert Vollmert Aug. 16, 2019, 12:22 p.m. UTC | #1
Hi John,

looks good to me! Hoogle builds and fine, and seems to run.

I’ve applied the patches to the wip-haskell-updates branch, will see
to get that merged soon.

Cheers
Robert

> On 16. Aug 2019, at 07:58, John Soo <jsoo1@asu.edu> wrote:
> 
> Hi Robert and Guix,
> 
> I realized just now that I had some incorrect git configuration. I have attached the updated patches with my correct email address.
> 
> Thanks again!
> 
> - John
> <0004-gnu-Add-ghc-storablevector.patch><0005-gnu-Add-ghc-fmlist.patch><0002-gnu-Add-ghc-non-negative.patch><0001-gnu-Add-ghc-unsafe.patch><0003-gnu-Add-ghc-timeit.patch><0007-gnu-Add-ghc-listlike.patch><0006-gnu-Add-ghc-storable-record.patch><0008-gnu-Add-ghc-storable-tuple.patch><0009-gnu-Add-ghc-process-extras.patch><0010-gnu-Add-ghc-js-jquery.patch><0011-gnu-Add-ghc-js-flot.patch><0012-gnu-Add-hoogle.patch>
John Soo Aug. 16, 2019, 1:58 p.m. UTC | #2
Excellent, thank you!

On Fri, Aug 16, 2019 at 12:22 PM Robert Vollmert <rob@vllmrt.net> wrote:

> Hi John,
>
> looks good to me! Hoogle builds and fine, and seems to run.
>
> I’ve applied the patches to the wip-haskell-updates branch, will see
> to get that merged soon.
>
> Cheers
> Robert
>
> > On 16. Aug 2019, at 07:58, John Soo <jsoo1@asu.edu> wrote:
> >
> > Hi Robert and Guix,
> >
> > I realized just now that I had some incorrect git configuration. I have
> attached the updated patches with my correct email address.
> >
> > Thanks again!
> >
> > - John
> >
> <0004-gnu-Add-ghc-storablevector.patch><0005-gnu-Add-ghc-fmlist.patch><0002-gnu-Add-ghc-non-negative.patch><0001-gnu-Add-ghc-unsafe.patch><0003-gnu-Add-ghc-timeit.patch><0007-gnu-Add-ghc-listlike.patch><0006-gnu-Add-ghc-storable-record.patch><0008-gnu-Add-ghc-storable-tuple.patch><0009-gnu-Add-ghc-process-extras.patch><0010-gnu-Add-ghc-js-jquery.patch><0011-gnu-Add-ghc-js-flot.patch><0012-gnu-Add-hoogle.patch>
>
>
Timothy Sample Sept. 3, 2019, 3:18 a.m. UTC | #3
Hi John,

I finally got around to processing the “wip-haskell-updates” branch
(thanks for your patience).  This patch series has now landed in master
as commits a52f4c5740–6ec2450f1e.

Thanks for the packages!

(And thanks to Robert too, for moving them into “haskell-xyz”.)


-- Tim
diff mbox series

Patch

From d02e4ed8a0b9357d1985d44fd638b8841014b3c9 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sun, 7 Jul 2019 18:03:26 -0700
Subject: [PATCH 12/12] gnu: Add hoogle.

* gnu/packages/haskell-apps.scm (hoogle): New variable.
---
 gnu/packages/haskell-apps.scm | 53 +++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index e77f6d113b..578dbaf2c3 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
 ;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -405,3 +406,55 @@  play inspired from classics Lemmings and The Incredible Machine.  The project
 proved to be an excellent learning experience for the programmers.  Everything
 is programmed in Haskell.")
     (license license:bsd-3)))
+
+(define-public hoogle
+  (package
+    (name "hoogle")
+    (version "5.0.17.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "https://hackage.haskell.org/package/hoogle/hoogle-"
+         version ".tar.gz"))
+       (sha256
+        (base32
+         "174gp41v0krzj37m75pnr3aawyhkbk2wq4q6zk2z3zh0avvvmgk6"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-network-uri" ,ghc-network-uri)
+       ("ghc-network" ,ghc-network)
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-aeson" ,ghc-aeson)
+       ("ghc-cmdargs" ,ghc-cmdargs)
+       ("ghc-conduit" ,ghc-conduit)
+       ("ghc-conduit-extra" ,ghc-conduit-extra)
+       ("ghc-connection" ,ghc-connection)
+       ("ghc-extra" ,ghc-extra)
+       ("ghc-old-locale" ,ghc-old-locale)
+       ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
+       ("ghc-http-conduit" ,ghc-http-conduit)
+       ("ghc-http-types" ,ghc-http-types)
+       ("ghc-js-flot" ,ghc-js-flot)
+       ("ghc-js-jquery" ,ghc-js-jquery)
+       ("ghc-mmap" ,ghc-mmap)
+       ("ghc-process-extras" ,ghc-process-extras)
+       ("ghc-resourcet" ,ghc-resourcet)
+       ("ghc-storable-tuple" ,ghc-storable-tuple)
+       ("ghc-tar" ,ghc-tar)
+       ("ghc-uniplate" ,ghc-uniplate)
+       ("ghc-utf8-string" ,ghc-utf8-string)
+       ("ghc-vector" ,ghc-vector)
+       ("ghc-wai" ,ghc-wai)
+       ("ghc-wai-logger" ,ghc-wai-logger)
+       ("ghc-warp" ,ghc-warp)
+       ("ghc-warp-tls" ,ghc-warp-tls)
+       ("ghc-zlib" ,ghc-zlib)))
+    (home-page "https://hoogle.haskell.org/")
+    (synopsis "Haskell API Search")
+    (description
+     "Hoogle is a Haskell API search engine, which allows you to search many
+standard Haskell libraries by either function name, or by approximate type
+signature.")
+    (license license:bsd-3)))
-- 
2.22.0