diff mbox series

[bug#37038] Amending author email

Message ID CAKf5CqU_fKu6bP71MJo7tVv-Jbw+CRJf03-PwiHe=GR5Scu09A@mail.gmail.com
State Accepted
Headers show
Series [bug#37038] Amending author email | expand

Commit Message

John Soo Aug. 28, 2019, 5:11 a.m. UTC
Hey everyone,

Sorry for that last response, stupid email client. Redoing that.  I would
love to use gnus for email but I think I need to work on a more recent
commit. Sorry for any formatting issues in my emails for now.

> Applied with a followup commit to address ‘guix lint’ warnings.

Thank you! I was unsure what to do about those lint errors. I updated
cedille with the proper fetch to fix the lint issues with it.

>  Also, it fails to build for me

I included a second patch to fix the build issue. It looks like this line
in the Makefile would cause this problem

./ial/ial.agda-lib:
    git submodule update --init --recursive

> To aid readability, I’d call the variable just ’lisp’; long names aren’t
> helpful for local variables IMO.

Fixed, I agree.

> Should it be a FIXME?

I made it a FIXME.

> ‘string-append’ is unnecessary.

Fixed, woops!.

> M-q here if you use Emacs.  :-)

I am an Emacs user but I do not know what M-q does (evil mode user, here).
What does it do?

Thanks again!

- John

Comments

John Soo Aug. 28, 2019, 5:17 a.m. UTC | #1
One last item:

> Could you (1) add this file to gnu/local.mk, and (2) address the
> remaining ‘guix lint’ warnings?

I thought my patches would fix the `guix lint` warnings, but they do not. I
do not know what to do about them, sorry.

Thanks again,

- John
Ricardo Wurmus Aug. 28, 2019, 5:23 a.m. UTC | #2
John Soo <jsoo1@asu.edu> writes:

>> M-q here if you use Emacs.  :-)
>
> I am an Emacs user but I do not know what M-q does (evil mode user, here).
> What does it do?

It runs ‘fill-paragraph‘ on the text at point.  (Or
’paredit-reindent-defun“ if you’re using paredit.)

--
Ricardo
diff mbox series

Patch

From 5602262a7785b8b1f60dbab8b0ad24351c33f7a2 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Mon, 12 Aug 2019 08:43:07 -0700
Subject: [PATCH 2/2] gnu: Add cedille.

* gnu/packages/cedille.scm: new file.
* gnu/packages/cedille.scm (cedille): new variable.
* gnu/local.mk (cedille): Add cedille.scm to GNU_SYSTEM_MODULES.
---
 gnu/local.mk             |   2 +
 gnu/packages/cedille.scm | 120 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 122 insertions(+)
 create mode 100644 gnu/packages/cedille.scm

diff --git a/gnu/local.mk b/gnu/local.mk
index a756316f77..8fb16a3ab6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -21,6 +21,7 @@ 
 # Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
 # Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 # Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+# Copyright © 2019 John Soo <jsoo1@asu.edu>
 #
 # This file is part of GNU Guix.
 #
@@ -99,6 +100,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/calcurse.scm			\
   %D%/packages/ccache.scm			\
   %D%/packages/cdrom.scm			\
+  %D%/packages/cedille.scm			\
   %D%/packages/certs.scm			\
   %D%/packages/check.scm			\
   %D%/packages/chemistry.scm			\
diff --git a/gnu/packages/cedille.scm b/gnu/packages/cedille.scm
new file mode 100644
index 0000000000..d5b4b63fa9
--- /dev/null
+++ b/gnu/packages/cedille.scm
@@ -0,0 +1,120 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cedille)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages agda)
+  #:use-module (gnu packages emacs-xyz)
+  #:use-module (gnu packages haskell)
+  #:use-module (gnu packages version-control)
+  #:use-module (guix build-system emacs)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages))
+
+(define-public cedille
+  (package
+    (name "cedille")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (url "https://github.com/cedille/cedille"
+                 (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "05b32fsshcjrbh9ysz4pfv5y5jndkycd7qrg8sdh4spnlf077r92"))))
+    (inputs
+     `(("agda" ,agda)
+       ("agda-ial" ,agda-ial)
+       ("ghc" ,ghc-8.4)
+       ("ghc-alex" ,ghc-alex)
+       ("ghc-happy" ,ghc-happy)
+       ("git" ,git)))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-cedille-path-el
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (substitute* "cedille-mode.el"
+                 (("/usr/share/emacs/site-lisp/cedille-mode")
+                  (string-append
+                   out "/share/emacs/site-lisp/guix.d/cedille-"
+                   ,version)))
+               #t)))
+         (add-after 'unpack 'copy-cedille-mode
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (lisp
+                     (string-append
+                      out "/share/emacs/site-lisp/guix.d/cedille-"
+                      ,version "/")))
+               (mkdir-p (string-append lisp "cedille-mode"))
+               (copy-recursively
+                "cedille-mode"
+                (string-append lisp "cedille-mode"))
+               (mkdir-p (string-append lisp "se-mode"))
+               (copy-recursively
+                "se-mode"
+                (string-append lisp "se-mode"))
+               #t)))
+         ;; FIXME: Byte compilation fails
+         (delete 'build)
+         (replace 'check
+           (lambda _
+             (with-directory-excursion "cedille-tests"
+               (invoke "sh" "run-tests.sh"))))
+         (add-after 'unpack 'patch-libraries
+           (lambda _ (patch-shebang "create-libraries.sh") #t))
+         (add-after 'unpack 'copy-ial
+           (lambda* (#:key inputs #:allow-other-keys)
+             (copy-recursively
+              (string-append (assoc-ref inputs "agda-ial")
+                             "/include/agda/ial")
+              "ial")
+             ;; Ambiguous module if main is included from ial
+             (delete-file "ial/main.agda")
+             #t))
+         (add-after 'check 'build-cedille
+           ;; Agda has a hard time with parallel compilation
+           (lambda _ (invoke "make" "--jobs=1")))
+         (add-after 'install 'install-cedille
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (copy-recursively
+                "lib" (string-append out "/lib/cedille"))
+               (install-file "cedille" (string-append out "/bin"))
+               (install-file "core/cedille-core"
+                             (string-append out "/bin"))
+               #t))))))
+    (home-page "https://cedille.github.io/")
+    (synopsis
+     "Language based on Calculus of Dependent Lambda Eliminations")
+    (description
+     "Cedille is an interactive theorem-prover and dependently
+typed programming language, based on extrinsic (aka Curry-style)
+type theory.  This makes it rather different from type theories
+like Coq and Agda, which are intrinsic (aka Church-style).  In
+Cedille, terms are nothing more than annotated versions of terms
+of pure untyped lambda calculus.  In contrast, in Coq or Agda,
+the typing annotations are intrinsic parts of terms.  The typing
+annotations can only be erased as an optimization under certain
+conditions, not by virtue of the definition of the type theory.")
+    (license license:expat)))
-- 
2.22.0