diff mbox series

[bug#46620] Fixed git patch

Message ID CAKSYu49pqONusDT99gyYze6s5RPZQ53a5yU=UVFY8+-=OM_b=w@mail.gmail.com
State Accepted
Headers show
Series [bug#46620] Fixed git patch | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Юрий Холодков Feb. 18, 2021, 6:37 p.m. UTC
From 923fe65c1b2461ebe8ecba7b85dcabedcb864e3b Mon Sep 17 00:00:00 2001
From: Yurii Kholodkov <urist.mckorobochka@gmail.com>
Date: Thu, 18 Feb 2021 20:11:10 +0300
Subject: [PATCH] gnu: emacs-kbd: new package

---
Hello!
 gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

sensible
+parenthesis handling.")
+      (license license:gpl3+))))
+
 (define-public emacs-keycast
   (package
     (name "emacs-keycast")

Comments

Nicolas Goaziou Feb. 18, 2021, 8:07 p.m. UTC | #1
Hello,

Юрий Холодков <urist.mckorobochka@gmail.com> writes:

> Subject: [PATCH] gnu: emacs-kbd: new package

I committed your patch with the minor changes detailed below.

> +       `(#:phases
> +         (modify-phases %standard-phases
> +           (add-after 'unpack 'enter-lisp-directory (lambda _ (chdir
> "lisp") #t)))))

I moved the lambda on the line below.

> +      (synopsis "Emacs minor mode for syntax highlighting kmonad's .kbd
> files.")

I slightly shortened synopsis and used @file{.kbd}.

> +      (description
> +       "This minor mode provides syntax highlighting for Lisp-like DSL
> used in kmonad's
> +configuration files (.kbd). It inherits from `emacs-lisp-mode' to provide
> sensible
> +parenthesis handling.")

I removed the second sentence in description, since it is not so useful
when trying to explain what the library is about. I also used
@file{.kbd}.

I added a copyright line for you at the top of the "emacs-xyz.scm" file.
I also added an appropriate commit message.

Note that your patch didn't apply cleanly. You may use "git
format-patch". If you did, something else broke your patch somehow.

Thanks!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cb2a5dc56f..c86732a164 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3146,6 +3146,36 @@  depicting stroke orders for all Kanji.  The
collection is a slightly modified
 and limited version of the images provided by the KanjiVG project.")
       (license license:gpl3+))))

+(define-public emacs-kbd
+  ;; Package has no release.  Version is extracted from "Version:" keyword
in
+  ;; main file.
+  (let ((commit "a7f4c9b9770fa6a58895c5f121df82652bb1b737")
+        (revision "0"))
+    (package
+      (name "emacs-kbd")
+      (version (git-version "0.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/slotThe/kbd-mode")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
"0jv9yfsncgf96308c041hvps3jlc151xb0aipm0vasbma3x83ygm"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'enter-lisp-directory (lambda _ (chdir
"lisp") #t)))))
+      (home-page "https://github.com/slotThe/kbd-mode")
+      (synopsis "Emacs minor mode for syntax highlighting kmonad's .kbd
files.")
+      (description
+       "This minor mode provides syntax highlighting for Lisp-like DSL
used in kmonad's
+configuration files (.kbd). It inherits from `emacs-lisp-mode' to provide