diff mbox series

[bug#47216] Update emilua to 0.3.0

Message ID CAK9RveJYM9yWNsYoNxTBjL32n5VwvbwA+b3KSe+SuO=PMb46jA@mail.gmail.com
State Accepted
Headers show
Series [bug#47216] Update emilua to 0.3.0 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinícius dos Santos Oliveira March 17, 2021, 9:07 p.m. UTC
Em qua., 17 de mar. de 2021 às 16:31, Efraim Flashner
<efraim@flashner.co.il> escreveu:
> Thanks. Some inlined comments.

Okay. You may find a new version of the patch attached.

> > * gnu/packages/lua.scm (emilua): Update to 0.3.0.
>
> The other changes should be listed here. For example
> [search-paths]: New field.

Fixed.

> > +      '("-Denable_http=true" "-Denable_tests=false" "-Dversion_suffix=-guix1")))
>
> Why are we adding '-guix1' as a version suffix?

$ emilua --version
Emilua 0.3.0-guix1

That's the only difference. When people fill bug reports, it'll make
it easy to identify which platform they're using.

> >     (native-inputs
> > -    `(("gcc" ,gcc-10) ; gcc-7 is too old for our C++17 needs
> > +    `(("asciidoctor" ,ruby-asciidoctor)
>
> If possible I'd prefer to not pull in ruby-asciidoctor, it pulls in
> pandoc, which will limit this package to GHC supported systems only, ie
> x86_64 and i686.

You sure about that? I failed to follow the dependencies track to pandoc.

In any case, asciidoctor is only used to build the manpages (and it
doesn't need pandoc here) and it'd be okay to cross-build. Also
manpage generation can be disabled easily with the flag
-Denable_manpages=false if desired. What's your call?

> > +      ("fmt" ,fmt)
>
> You'll also need to import pretty-print at the top of the file.

My bad. Fixed.

> > +   (native-search-paths
> > +    (list (search-path-specification
> > +           (variable "EMILUA_PATH")
> > +           (files '("lib/emilua-0.3")))))
>
> this can be (list (string-append "/lib/emilua-"
>             (version-major+minor version)))

Fixed.


--
Vinícius dos Santos Oliveira
https://vinipsmaker.github.io/

Comments

Efraim Flashner March 21, 2021, 9:07 a.m. UTC | #1
Thanks. I disabled the manpages to remove the dependency on asciidoctor.

Patch pushed!
diff mbox series

Patch

From 36c446d4a9c65bbb50ee21a7535cb62ca3f64d4d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Vin=C3=ADcius=20dos=20Santos=20Oliveira?=
 <vini.ipsmaker@gmail.com>
Date: Wed, 17 Mar 2021 18:03:31 -0300
Subject: [PATCH] gnu: emilua: Update to 0.3.0.

* gnu/packages/lua.scm (emilua): Update to 0.3.0.
* gnu/packages/lua.scm (emilua): Update deps to match newer version.
* gnu/packages/lua.scm (emilua): [search-paths]: New field.
* gnu/packages/lua.scm (emilua): Enable HTTP module.
* gnu/packages/lua.scm (emilua): "-Dversion_suffix=-guix1".
---
 gnu/packages/lua.scm | 23 +++++++++++++++++------
 1 file changed, 17 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 16996572d7..67cc00d641 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -56,6 +56,8 @@ 
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages vim)
   #:use-module (gnu packages re2c)
+  #:use-module (gnu packages pretty-print)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages gtk))
 
@@ -1108,14 +1110,14 @@  shell command executions.")
 (define-public emilua
   (package
    (name "emilua")
-   (version "0.2.1")
+   (version "0.3.0")
    (source (origin
             (method git-fetch)
             (uri (git-reference
                   (url "https://gitlab.com/emilua/emilua.git")
                   (commit (string-append "v" version))
-                  ;; Current version requires bundled CLI11 and fmt, but at some
-                  ;; future release the ones found in the system could be used
+                  ;; Current version requires bundled CLI11, but at some future
+                  ;; release the one found in the system could be used
                   ;; instead. Current version also requires Trial.Protocol and
                   ;; the HTTP lib developed as part of GSoC 2014 for Boost, but
                   ;; these are dependencies unlikely to be "unbundled" in future
@@ -1124,15 +1126,17 @@  shell command executions.")
             (file-name (git-file-name name version))
             (sha256
              (base32
-              "1d6k5v6x85fbvz2ijq1imnfdwvqmsav4xp021a5v3ah4mgy7yann"))))
+              "124fj73722c03znwdyqp1i0jygwv3s11f6s1j9rzym513qrf7fnd"))))
    (build-system meson-build-system)
    (arguments
     `(#:meson ,meson-0.55
       ;; Tests are disabled for now due to an issue that affecs guix:
       ;; <https://gitlab.com/emilua/emilua/-/issues/22>
-      #:configure-flags '("-Denable_http=false" "-Denable_tests=false")))
+      #:configure-flags
+      '("-Denable_http=true" "-Denable_tests=false" "-Dversion_suffix=-guix1")))
    (native-inputs
-    `(("gcc" ,gcc-10) ; gcc-7 is too old for our C++17 needs
+    `(("asciidoctor" ,ruby-asciidoctor)
+      ("gcc" ,gcc-10) ; gcc-7 is too old for our C++17 needs
       ("luajit-lua52-openresty" ,luajit-lua52-openresty)
       ("pkg-config" ,pkg-config)
       ("re2c" ,re2c)
@@ -1140,6 +1144,7 @@  shell command executions.")
    (inputs
     `(("boost" ,boost)
       ("boost-static" ,boost-static)
+      ("fmt" ,fmt)
       ;; LuaJIT has a 2GiB addressing limit[1] that has been fixed on OpenResty
       ;; fork. Emilua is severely affected by this limit, so the upstream package
       ;; is avoided. Emilua also depends on the -DLUAJIT_ENABLE_LUA52COMPAT
@@ -1151,6 +1156,12 @@  shell command executions.")
       ("luajit-lua52-openresty" ,luajit-lua52-openresty)
       ("ncurses" ,ncurses)
       ("openssl" ,openssl)))
+   (native-search-paths
+    (list
+     (search-path-specification
+      (variable "EMILUA_PATH")
+      (files
+       (list (string-append "lib/emilua-" (version-major+minor version)))))))
    (home-page "https://gitlab.com/emilua/emilua")
    (synopsis "Lua execution engine")
    (description
-- 
2.30.2