diff mbox series

[bug#46231] Add emilua

Message ID CAK9Rve+mtdU3=Qmxku_ny2M2Q22oe8AzzD_M-KO3+Z5L_423qg@mail.gmail.com
State Accepted
Headers show
Series [bug#46231] Add emilua | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinícius dos Santos Oliveira Feb. 23, 2021, 8:35 p.m. UTC
Em seg., 22 de fev. de 2021 às 07:04, Nicolas Goaziou
<mail@nicolasgoaziou.fr> escreveu:
> The trend in other distributions is to use luajit-openresty, in this
> order. So maybe luajit-lua52-openresty? Or luajit-openresty if that is
> unambiguous. It is not a big issue anyway.

luajit-openresty might be ambiguous as not every package might depend
on the lua52 configure flag, so I renamed it to
luajit-lua52-openresty.

> Could you send this to this ML using git format-patch?

You may find the patch with the requested fixes attached to this
email. I'll implement the changes to the other package once we have
luajit-lua52-openresty in place.

Thanks for acting as the reviewer of this patch.

Comments

Nicolas Goaziou Feb. 24, 2021, 1:07 p.m. UTC | #1
Hello,

Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com> writes:

> luajit-openresty might be ambiguous as not every package might depend
> on the lua52 configure flag, so I renamed it to
> luajit-lua52-openresty.

OK.

> You may find the patch with the requested fixes attached to this
> email. I'll implement the changes to the other package once we have
> luajit-lua52-openresty in place.

You didn't include "luajit-enable-lua52compat.patch". Could you send it
too?

Also, there is a new release: 2.1-20201229. You may want to send an
updated version. I can also update it.

Thanks!

Regards,
diff mbox series

Patch

From c5d11f986595637ae72d551acf0bf2cd15390a39 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Vin=C3=ADcius=20dos=20Santos=20Oliveira?=
 <vini.ipsmaker@gmail.com>
Date: Tue, 23 Feb 2021 17:25:07 -0300
Subject: [PATCH] Add luajit-lua52-openresty

---
 gnu/packages/lua.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index b029400cb2..8fbcc0b317 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -157,6 +157,35 @@  language.  It may be embedded or used as a general-purpose, stand-alone
 language.")
     (license license:x11)))
 
+(define-public luajit-lua52-openresty
+  (package
+   (inherit luajit)
+   (name "luajit-lua52-openresty")
+   (version "2.1-20201027")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/openresty/luajit2.git")
+                  (commit (string-append "v" version))))
+            (sha256
+             (base32
+              "115gixlbik4fx62bv8m1psfvv48alcvg3hki5kz3hcpa830gd7zp"))
+            (patches (search-patches
+                      "luajit-enable-lua52compat.patch"))))
+   (arguments
+    `(#:tests? #f
+      #:phases (modify-phases %standard-phases
+                              (delete 'configure))
+      #:make-flags (list
+                    (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+   (synopsis "OpenResty's Branch of LuaJIT 2")
+   (description
+    "This package provides the official OpenResty branch of LuaJIT. It is not to
+be considered a fork, since changes are regularly synchronized from the upstream
+LuaJIT project. This package also enables the Lua 5.2 compat mode needed by some
+projects.")
+   (home-page "https://github.com/openresty/luajit2")))
+
 (define (make-lua-expat name lua)
   (package
     (name name)
-- 
2.30.1