diff mbox series

[bug#70467] Add the Texinfo adaptation of the R7RS-small standard.

Message ID CAK0OjG2pPjr+juq3sMNkgyEfp9xWkU8gMaZgKaJzxpiuhOYf4Q@mail.gmail.com
State New
Headers show
Series [bug#70467] Add the Texinfo adaptation of the R7RS-small standard. | expand

Commit Message

Yuval Langer May 12, 2024, 12:21 a.m. UTC
On Sun, May 12, 2024 at 3:16 AM Yuval Langer <yuval.langer@gmail.com> wrote:
>
> […] I fixed a problem in this patch. […]

Oops, sent the old one.  Now it's definitely the fixed one.

Comments

Ludovic Courtès May 31, 2024, 11:37 a.m. UTC | #1
Hi,

Yuval Langer <yuval.langer@gmail.com> skribis:

> From 030218776a77edf8d5c1c68ca715f5e5d276d901 Mon Sep 17 00:00:00 2001
> Message-Id: <030218776a77edf8d5c1c68ca715f5e5d276d901.1715473093.git.yuval.langer@gmail.com>
> From: Yuval Langer <yuval.langer@gmail.com>
> Date: Fri, 19 Apr 2024 05:22:08 +0300
> Subject: [PATCH] Add the Texinfo adaptation of the R7RS-small Scheme standard.

I tweaked the commit log to follow our conventions and applied it.
Thanks!

Ludo’.
diff mbox series

Patch

From 030218776a77edf8d5c1c68ca715f5e5d276d901 Mon Sep 17 00:00:00 2001
Message-Id: <030218776a77edf8d5c1c68ca715f5e5d276d901.1715473093.git.yuval.langer@gmail.com>
From: Yuval Langer <yuval.langer@gmail.com>
Date: Fri, 19 Apr 2024 05:22:08 +0300
Subject: [PATCH] Add the Texinfo adaptation of the R7RS-small Scheme standard.

---
 gnu/packages/scheme.scm | 45 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index a91a2d693d..47754800f9 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1314,3 +1314,48 @@  as well as light.  The implementation is based on an ad-hoc Virtual
 Machine.  STklos can also be compiled as a library and embedded in an
 application.")
     (license gpl2+)))
+
+(define-public r7rs-small-texinfo
+  (let ((commit "38a703976ea6353e32b52a5187dbdaf77fb2f050")
+        (revision "3"))
+    (package
+      (name "r7rs-small-texinfo")
+      (version (git-version "0.1.0" revision commit))
+      (home-page "https://codeberg.org/Zipheir/r7rs-small-texinfo/")
+      (source
+       (origin
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (method git-fetch)
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1fr02fyhiwd364jkfy1n5w31pq3kx1rl5w634421g05702yb47x3"))))
+      (native-inputs (list bash texinfo))
+      (inputs '())
+      (build-system copy-build-system)
+      (arguments
+       (list
+        #:install-plan #~'(("r7rs-small.info" "share/info/"))
+        #:phases #~(modify-phases %standard-phases
+                     (add-after 'unpack 'compile-the-files
+                       (lambda _
+                         (let* ((source-directory-path (string-append (getcwd)
+                                                        "/doc/r7rs-small"))
+                                (build-script-path (string-append
+                                                    source-directory-path
+                                                    "/build.sh"))
+                                (info-directory-path (string-append #$output
+                                                      "/share/info")))
+                           (chdir source-directory-path)
+                           (system* "bash" build-script-path "info")
+                           (mkdir-p info-directory-path)
+                           (copy-file (string-append source-directory-path
+                                                     "/r7rs-small.info")
+                                      (string-append info-directory-path
+                                                     "/r7rs-small.info"))))))))
+      (synopsis
+       "R7RS Small standard of the Scheme programming language in Info format")
+      (description
+       "Revised^7 Report of the Algorithmic Language Scheme adapted to Texinfo format.")
+      (license (non-copyleft "file://COPYING")))))
-- 
2.30.2