diff mbox series

[bug#70467] Add the Texinfo adaptation of the R7RS-small standard.

Message ID CAK0OjG2Z5ppjVahXo41m7t0oxqXQAfYc5LpunogMCYNo4UtGkg@mail.gmail.com
State New
Headers show
Series [bug#70467] Add the Texinfo adaptation of the R7RS-small standard. | expand

Commit Message

Yuval Langer April 19, 2024, 2:32 a.m. UTC
Hi,

provided is a package definition for the Wolfgang Corcoran-Mathe
Texinfo adaptation[1] of the R7RS-small standard.

Hope it would come in handy,
Yuval (Yulav) Langer.

[1]: <https://codeberg.org/Zipheir/r7rs-small-texinfo>
diff mbox series

Patch

From 6304e1faabe79eb601ff09ed5d95c8db11780576 Mon Sep 17 00:00:00 2001
Message-Id: <6304e1faabe79eb601ff09ed5d95c8db11780576.1713493331.git.yuval.langer@gmail.com>
From: Yuval Langer <yuval.langer@gmail.com>
Date: Fri, 19 Apr 2024 05:22:08 +0300
Subject: [PATCH] Add the Texinfo adaptation of the R7RS-small Scheme standard.

---
 gnu/packages/scheme.scm | 44 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index a91a2d693d..9177801800 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1314,3 +1314,47 @@  as well as light.  The implementation is based on an ad-hoc Virtual
 Machine.  STklos can also be compiled as a library and embedded in an
 application.")
     (license gpl2+)))
+
+(define-public r7rs-small-texinfo
+  (let ((commit "38a703976ea6353e32b52a5187dbdaf77fb2f050")
+        (revision "2"))
+    (package
+      (name "r7rs-small-texinfo")
+      (version (git-version "0.1.0" revision commit))
+      (home-page "https://codeberg.org/Zipheir/r7rs-small-texinfo/")
+      (source
+       (origin
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (method git-fetch)
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1fr02fyhiwd364jkfy1n5w31pq3kx1rl5w634421g05702yb47x3"))))
+      (native-inputs (list bash texinfo))
+      (inputs '())
+      (build-system copy-build-system)
+      (arguments
+       (list
+        #:phases #~(modify-phases %standard-phases
+                     (add-after 'unpack 'compile-the-files
+                       (lambda _
+                         (let* ((source-directory-path (string-append (getcwd)
+                                                        "/doc/r7rs-small"))
+                                (build-script-path (string-append
+                                                    source-directory-path
+                                                    "/build.sh"))
+                                (info-directory-path (string-append #$output
+                                                      "/share/info")))
+                           (chdir source-directory-path)
+                           (system* "bash" build-script-path "info")
+                           (mkdir-p info-directory-path)
+                           (copy-file (string-append source-directory-path
+                                                     "/r7rs-small.info")
+                                      (string-append info-directory-path
+                                                     "/r7rs-small.info"))))))))
+      (synopsis
+       "R7RS Small standard of the Scheme programming language in Info format")
+      (description
+       "Revised^7 Report of the Algorithmic Language Scheme adapted to Texinfo format.")
+      (license (non-copyleft "file://COPYING")))))
-- 
2.30.2