diff mbox series

[bug#52215] gnu: bullet: Update to 3.17

Message ID CAJsg1E_hFQsFZu4xjjXp2hEhQcjDAzWFB=cRMkhiAEgxp+4YRw@mail.gmail.com
State Accepted
Headers show
Series [bug#52215] gnu: bullet: Update to 3.17 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andy Tai Dec. 1, 2021, 5:24 a.m. UTC
* gnu/packages/game-development.scm (bullet): Update to 3.17
---
 gnu/packages/game-development.scm | 16 +++++++++++-----
 1 file changed, 11 insertions(+), 5 deletions(-)

                                                (or (getenv "CXXFLAGS") "")))
        #:phases

Comments

Nicolas Goaziou Dec. 1, 2021, 3:46 p.m. UTC | #1
Hello,

Andy Tai <atai@atai.org> writes:

> * gnu/packages/game-development.scm (bullet): Update to 3.17

Nitpick: you need to add periods at the end of the two lines in the
commit message.

But more importantly, I cannot apply your patch cleany on top of master
branch. Could you try rebasing your change and send the patch again?

Thanks!

Regards,
Andy Tai Dec. 1, 2021, 6:12 p.m. UTC | #2
OK, will do the rebase and re-send

On Wed, Dec 1, 2021 at 7:46 AM Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>
> Hello,
>
> Andy Tai <atai@atai.org> writes:
>
> > * gnu/packages/game-development.scm (bullet): Update to 3.17
>
> Nitpick: you need to add periods at the end of the two lines in the
> commit message.
>
> But more importantly, I cannot apply your patch cleany on top of master
> branch. Could you try rebasing your change and send the patch again?
>
> Thanks!
>
> Regards,
> --
> Nicolas Goaziou
Leo Famulari Dec. 2, 2021, 3:58 a.m. UTC | #3
On Wed, Dec 01, 2021 at 04:46:47PM +0100, Nicolas Goaziou wrote:
> But more importantly, I cannot apply your patch cleany on top of master
> branch. Could you try rebasing your change and send the patch again?

When generating the patches with `git format-patch` or `git send-email`,
you can add the argument '--base=auto', which adds a note to the patch
about what commit the patch is based on.

That helps reviewers figure out how to apply the patch.

There's a note about this in the manual section Submitting Patches, but
it's not totally clear. I'll think about improving it.
Simon Tournier Dec. 2, 2021, 8:40 a.m. UTC | #4
Hi Leo,

On Thu, 2 Dec 2021 at 04:59, Leo Famulari <leo@famulari.name> wrote:

> When generating the patches with `git format-patch` or `git send-email`,
> you can add the argument '--base=auto', which adds a note to the patch
> about what commit the patch is based on.

The argument 'auto' often breaks for me.  I mean, I am not sure the
manual should have:

        We recommend to use the command 'git format-patch --base=auto'
        to include the commit where your patch applies.

but 'auto' should only be an advice or a recommendation as suggested
parameter for the otpion '--base'.  IMHO.


> There's a note about this in the manual section Submitting Patches, but
> it's not totally clear. I'll think about improving it.

Cool! :-)

Thanks,
Cheers,
Leo Famulari Dec. 2, 2021, 7:32 p.m. UTC | #5
On Thu, Dec 02, 2021 at 09:40:12AM +0100, zimoun wrote:
> The argument 'auto' often breaks for me.  I mean, I am not sure the
> manual should have:
> 
>         We recommend to use the command 'git format-patch --base=auto'
>         to include the commit where your patch applies.
> 
> but 'auto' should only be an advice or a recommendation as suggested
> parameter for the otpion '--base'.  IMHO.

Okay, I took your advice and pushed my change to the manual as
f697fc267c317e98e4bba8009452b9d64e76b30a

I hope it helps!
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm
b/gnu/packages/game-development.scm
index 55bbad30e6..1b802d662f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -24,6 +24,7 @@ 
 ;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
 ;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -112,7 +113,7 @@  (define-module (gnu packages game-development)
 (define-public bullet
   (package
     (name "bullet")
-    (version "2.89")
+    (version "3.17")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -121,7 +122,7 @@  (define-public bullet
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "10ncf2z474jnv7p5lv01ak2mk2hib3rj5rz1zr8v2v5pnciqbijl"))
+                "0x1ghxbkvqr910sp01sjf4hlfy4sdgn2jx2qf0dsi697bzq1f3mr"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -131,9 +132,7 @@  (define-public bullet
                               '("Gwen" "clsocket" "enet" "glad" "imgui"
                                 "lua-5.2.3" "midi" "minizip" "openvr"
                                 "optionalX11" "serial" "zlib")))
-                  ;; These need files from ThirdPartyLibs.
-                  (substitute* "Extras/CMakeLists.txt"
-                    (("BulletRobotics") ""))
+
                   ;; Tests fail on linking, cannot find -lBussIK.
                   (substitute* "test/CMakeLists.txt"
                     ((" InverseDynamics")
@@ -146,6 +145,13 @@  (define-public bullet
                                "-DBUILD_CPU_DEMOS=OFF"
                                "-DBUILD_OPENGL3_DEMOS=OFF"
                                "-DBUILD_BULLET2_DEMOS=OFF"
+
+                               ;; Extras/BulletRoboticsGUI needs
files from ThirdPartyLibs
+                               "-DBUILD_BULLET_ROBOTICS_GUI_EXTRA=OFF"
+
+                               ;; Extras/BulletRobotics needs files
from ThirdPartyLibs
+                               "-DBUILD_BULLET_ROBOTICS_EXTRA=OFF"
+
                                (string-append  "-DCMAKE_CXX_FLAGS=-fPIC "