diff mbox series

[bug#46675] gnu: Add python-sane

Message ID CAJsg1E_UZsWnDoC4yH3YVC=QhotJDOH2A1vpMaHqe+hgpPGW9w@mail.gmail.com
State Accepted
Headers show
Series [bug#46675] gnu: Add python-sane | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andy Tai Feb. 21, 2021, 6:30 a.m. UTC
* gnu/packages/python-xyz.scm (python-sane): New variable
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

+    ;; MIT license; FSF directory refers to this as expat licene
+    (license license:expat)))

Comments

Ludovic Courtès Feb. 22, 2021, 11:11 a.m. UTC | #1
Hi Andy,

Andy Tai <lichengtai@gmail.com> skribis:

> * gnu/packages/python-xyz.scm (python-sane): New variable

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b26fce72a9..1fb9ff60b4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -180,6 +180,7 @@ 
   #:use-module (gnu packages readline)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages search)
+  #:use-module (gnu packages scanner)
   #:use-module (gnu packages shells)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages ssh)
@@ -23906,3 +23907,26 @@  Application Programming Interface based on
the Open Inventor 2.1 API.")
 Crayons automatically wraps a given string in the foreground color and
 restores the original state after the string is printed.")
     (license license:expat)))
+
+(define-public python-sane
+  (package
+    (name "python-sane")
+    (version "2.9.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri name version))
+        (sha256
+          (base32
+            "1pi597z94n2mkd821ln52fq0g727n2jxfskf280ip3kf7jw8w294"))))
+    (build-system python-build-system)
+    (native-inputs
+      `(("python-pytest" ,python-pytest)))
+    (inputs
+      `(("sane-backends" ,sane-backends)))
+    (home-page "https://github.com/python-pillow/Sane")
+    (synopsis "Python interface to the SANE scanner")
+    (description "This package provides Python interface to the SANE
scanner and
+frame grabber interface for Linux.")