diff mbox series

[bug#59059] gnu: terminator: Renamed to "gnome-terminator" and update to 2.1.2

Message ID CAJsg1E_OjaReYXyX_VvgCjQaJoi8w0-2AszFQYGdSyHJi4ecXw@mail.gmail.com
State New
Headers show
Series [bug#59059] gnu: terminator: Renamed to "gnome-terminator" and update to 2.1.2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Andy Tai Nov. 5, 2022, 7:45 p.m. UTC

Comments

Simon Tournier Jan. 11, 2023, 10:09 p.m. UTC | #1
Hi,

This patch LGTM except two minor comments.

On Sat, 05 Nov 2022 at 12:45, Andy Tai <atai@atai.org> wrote:

> * gnu/packages/gnome.scm (gnome-terminator): Rename variable from
> (terminator(:  …this.  Redefine using DEPRECATED-PACKAGE.
           --^
       Here

> +(define-public terminator
> +    (deprecated-package "terminator" gnome-terminator))
> +

Incorrect indentation.  Well, I noticed that it was also the case for
other of your submissions.  Maybe, give a look at your editor settings –
if it is Emacs, the repository contains .dir-locals.el which implements
the convention.


Cheers,
simon
diff mbox series

Patch

From f163a30edb7d0ed40c0e27eae4ee403c1970c091 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Fri, 4 Nov 2022 22:58:08 -0700
Subject: [PATCH] gnu: terminator: Renamed to "gnome-terminator" and update to
 2.1.2
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/gnome.scm (gnome-terminator): Rename variable from
(terminator(:  …this.  Redefine using DEPRECATED-PACKAGE.
Update to 2.1.2
---
 gnu/packages/gnome.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1246ac22b3..59f1e72679 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11779,18 +11779,18 @@  (define-public gthumb
 advanced image management tool")
     (license license:gpl2+)))
 
-(define-public terminator
+(define-public gnome-terminator
   (package
-    (name "terminator")
-    (version "2.1.1")
+    (name "gnome-terminator")
+    (version "2.1.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/gnome-terminator/terminator/"
                            "releases/download/v" version "/"
-                           name "-" version ".tar.gz"))
+                           "terminator" "-" version ".tar.gz"))
        (sha256
-        (base32 "0xdgmam7ghnxw6g38a4gjw3kk3rhga8c66lns18k928jlr9fmddw"))))
+        (base32 "10shpn8id7z43d4dpx16x76mgxnk4mr976j5cg28icjiiaidyfc2"))))
     (build-system python-build-system)
     (native-inputs
      `(("gettext" ,gettext-minimal)
@@ -11852,6 +11852,9 @@  (define-public terminator
 tabs, and it supports drag and drop re-ordering of terminals.")
     (license license:gpl2)))
 
+(define-public terminator
+    (deprecated-package "terminator" gnome-terminator))
+
 (define-public libhandy
   (package
     (name "libhandy")
-- 
2.38.0