diff mbox series

[bug#46393] gnu: Add ocrfeeder

Message ID CAJsg1E_AiXG9H-6ucf6J-KJ_fAk=ufQhQUzO6o2U31XXb47eVA@mail.gmail.com
State Accepted
Headers show
Series [bug#46393] gnu: Add ocrfeeder | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andy Tai Feb. 24, 2021, 2:09 a.m. UTC
sent the wrong one; here is the correct one


On Tue, Feb 23, 2021 at 5:59 PM Andy Tai <atai@atai.org> wrote:
>
> as attached
>
> > On Tue, Feb 23, 2021 at 12:06 PM Leo Famulari <leo@famulari.name> wrote:
> > > Can you send a revised patch?

Comments

Leo Famulari Feb. 24, 2021, 4:08 p.m. UTC | #1
On Tue, Feb 23, 2021 at 06:09:59PM -0800, Andy Tai wrote:
> From 2db7eaf5dc51df1f2546357a3a87f73bce089148 Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Sat, 20 Feb 2021 22:58:07 -0800
> Subject: [PATCH] gnu: Add ocrfeeder
> 
> * gnu/packages/gnome.scm (ocrfeeder): New variable

Thanks! Pushed as 02e0aa255933197d6c95ab9b66251ef0885b237e
Andy Tai Feb. 24, 2021, 7:04 p.m. UTC | #2
Thanks!

On Wed, Feb 24, 2021 at 8:08 AM Leo Famulari <leo@famulari.name> wrote:
>
> On Tue, Feb 23, 2021 at 06:09:59PM -0800, Andy Tai wrote:
> > From 2db7eaf5dc51df1f2546357a3a87f73bce089148 Mon Sep 17 00:00:00 2001
> > From: Andy Tai <atai@atai.org>
> > Date: Sat, 20 Feb 2021 22:58:07 -0800
> > Subject: [PATCH] gnu: Add ocrfeeder
> >
> > * gnu/packages/gnome.scm (ocrfeeder): New variable
>
> Thanks! Pushed as 02e0aa255933197d6c95ab9b66251ef0885b237e
diff mbox series

Patch

From 2db7eaf5dc51df1f2546357a3a87f73bce089148 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sat, 20 Feb 2021 22:58:07 -0800
Subject: [PATCH] gnu: Add ocrfeeder

* gnu/packages/gnome.scm (ocrfeeder): New variable
---
 gnu/packages/gnome.scm | 67 +++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 66 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b8634d712a..32cecb75b5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -56,7 +56,7 @@ 
 ;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
-;;; Copyright © 2020 Andy Tai <atai@atai.org>
+;;; Copyright © 2020, 2021 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -149,6 +149,7 @@ 
   #:use-module (gnu packages ninja)
   #:use-module (gnu packages node)
   #:use-module (gnu packages nss)
+  #:use-module (gnu packages ocr)
   #:use-module (gnu packages openldap)
   #:use-module (gnu packages package-management)
   #:use-module (gnu packages password-utils)
@@ -12097,3 +12098,67 @@  for the GNOME 3.x platform with many features.  It aims to be a very complete
 editing environment for translation issues within the GNU gettext/GNOME desktop
 world.")
     (license license:gpl3+)))
+
+
+(define-public ocrfeeder
+  (package
+    (name "ocrfeeder")
+    (version "0.8.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/ocrfeeder/"
+                                  (version-major+minor version) "/"
+                                  "ocrfeeder-" version ".tar.xz"))
+              (sha256
+               (base32
+                "12f5gnq92ffnd5zaj04df7jrnsdz1zn4zcgpbf5p9qnd21i2y529"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after
+          'install 'wrap-program
+          (lambda* (#:key outputs #:allow-other-keys)
+            (let ((prog (string-append (assoc-ref outputs "out")
+                                       "/bin/" "ocrfeeder"))
+                  (pylib (string-append (assoc-ref outputs "out")
+                                        "/lib/python"
+                                        ,(version-major+minor
+                                          (package-version python))
+                                        "/site-packages")))
+              (wrap-program prog
+                `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+                `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+              #t))))))
+    (native-inputs
+     `(("glib:bin" ,glib "bin")                   ; for glib-compile-resources
+       ("gobject-introspection" ,gobject-introspection)
+       ("gtk+:bin" ,gtk+ "bin")                   ; for gtk-update-icon-cache
+       ("intltool" ,intltool)
+       ("itstool" ,itstool)
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
+    (inputs
+     `(("enchant" ,enchant)
+       ("glib" ,glib)
+       ("goocanvas" ,goocanvas)
+       ("gtk" ,gtk+)
+       ("gtkspell3" ,gtkspell3)
+       ("libjpeg" ,libjpeg-turbo)
+       ("libtiff" ,libtiff)
+       ("libraw" ,libraw)
+       ("ocrad" ,ocrad)
+       ("python" ,python-wrapper)
+       ("python-pygobject" ,python-pygobject)
+       ("python-odfpy" ,python-odfpy)
+       ("python-pillow" ,python-pillow)
+       ("python-pyenchant" ,python-pyenchant)
+       ("python-reportlab" ,python-reportlab)
+       ("python-sane" ,python-sane)
+       ("sane-backends" ,sane-backends)
+       ("tesseract-ocr" ,tesseract-ocr)))
+    (home-page "https://wiki.gnome.org/Apps/OCRFeeder")
+    (synopsis "Complete OCR Suite")
+    (description "OCRFeeder is a complete Optical Character Recognition and
+Document Analysis and Recognition program.")
+    (license license:gpl3+)))
-- 
2.30.1