diff mbox series

[bug#60979] gnu: wlroots: Update dependencies

Message ID CAJsg1E_9tM4qWbuynwTdYh5g3V6myVxfUbcU9hyHFU=mZLZGWw@mail.gmail.com
State New
Headers show
Series [bug#60979] gnu: wlroots: Update dependencies | expand

Commit Message

Andy Tai Jan. 21, 2023, 4:48 a.m. UTC

Comments

Josselin Poiret Feb. 3, 2023, 9:48 a.m. UTC | #1
Hi Andry,

First of all, looking at QA [1], I noticed that none of the WMs
depending on it actually build.  Have you tested this patch on your
machine?

Andy Tai <lichengtai@gmail.com> writes:

> From 2d433dba9ee73707ec71a4209e023e91e10d094d Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Fri, 20 Jan 2023 20:43:50 -0800
> Subject: [PATCH] gnu: wlroots: Update dependencies
>
> gnu/packages/wm.scm (wlroots): Add input xcb-util-renderutil and vulkan
> for XWayland support
> ---
>  gnu/packages/wm.scm | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 201c5994d8..b93c57b888 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -143,6 +143,7 @@ (define-module (gnu packages wm)
>    #:use-module (gnu packages textutils)
>    #:use-module (gnu packages time)
>    #:use-module (gnu packages video)
> +  #:use-module (gnu packages vulkan)
>    #:use-module (gnu packages web)
>    #:use-module (gnu packages xdisorg)
>    #:use-module (gnu packages xml)
> @@ -1555,6 +1556,7 @@ (define-public wlroots
>                                                         "xorg-server-xwayland")
>                                              "/bin/Xwayland")))
>               #t)))))
> +    (inputs (list libpng  mesa-headers vulkan-headers vulkan-loader xcb-util-renderutil))

Here, xcb-util-renderutil should be propagated because it is required by
the wlroots.pc pkg-config file.  Also, looking at the wlroots README, I
don't see libpng mentioned anywhere, as well as mesa-headers, and
removing both of them still lets it build fine. Do you know if those are
actually needed? Reciprocally, glslang is mentioned for the Vulkan
renderer, but I don't see it here.

>      (propagated-inputs
>       (list ;; As required by wlroots.pc.
>             eudev

Best,
Andy Tai Feb. 4, 2023, 4:55 a.m. UTC | #2
OK, I will close this issue as this seems complicated and will let
other people handle this package.

>
> >      (propagated-inputs
> >       (list ;; As required by wlroots.pc.
> >             eudev
>
> Best,
> --
> Josselin Poiret
diff mbox series

Patch

From 2d433dba9ee73707ec71a4209e023e91e10d094d Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Fri, 20 Jan 2023 20:43:50 -0800
Subject: [PATCH] gnu: wlroots: Update dependencies

gnu/packages/wm.scm (wlroots): Add input xcb-util-renderutil and vulkan
for XWayland support
---
 gnu/packages/wm.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 201c5994d8..b93c57b888 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -143,6 +143,7 @@  (define-module (gnu packages wm)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages time)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages vulkan)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml)
@@ -1555,6 +1556,7 @@  (define-public wlroots
                                                        "xorg-server-xwayland")
                                             "/bin/Xwayland")))
              #t)))))
+    (inputs (list libpng  mesa-headers vulkan-headers vulkan-loader xcb-util-renderutil))
     (propagated-inputs
      (list ;; As required by wlroots.pc.
            eudev
-- 
2.39.1