diff mbox series

[bug#46376] gnu: tesseract-ocr: update to 4.1.1)

Message ID CAJsg1E9H14+5jU674DOZW9g=HfB0cmAEa8KgGiDoo8ga+7JKOg@mail.gmail.com
State Accepted
Headers show
Series [bug#46376] gnu: tesseract-ocr: update to 4.1.1) | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andy Tai Feb. 10, 2021, 7:52 a.m. UTC
updated patch, now tests build in parallel... the build order has to
be explicitly set to make the training target built first

also added some other optional dependencies; built in a GuixSD VM to
ensure no dependency on non-Guix tools from host

test run is disabled for now

On Tue, Feb 9, 2021 at 2:43 PM Jelle Licht <jlicht@posteo.net> wrote:
>
> Hi Andy,
>
> Andy Tai <atai@atai.org> writes:
>
> > Hi, I updated the patch to only build in serial, with "-j 1"
> >
> > and with this, everything, including tests, builds successfully.
>
> No such luck, for me at least. Are you certain you got it to build on
> your end? Could you try with `--check`?
>
> I've had to work out the following things:
>
> - Patched out "<tesseract/baseapi.h>" and "<tesseract/helpers.h>" to
>   refer to "baseapi.h" and "helpers.h" in "unittest/pagesegmode_test.cc".
>
> - Make sure the check phase takes place after running "make training" in
>   a phase.
>
> I still ended up with several failing tests, courtesy of it running
> unsupported instructions on my cpu (educated guess: avx etc). Nothing
> comes easy, I guess.
>
> Thanks,
>  - Jelle
diff mbox series

Patch

From d3287d74861824dc3a7e2b65e11cd33fa0a11b39 Mon Sep 17 00:00:00 2001
From: andy Tai <atai@atai.org>
Date: Tue, 9 Feb 2021 23:44:06 -0800
Subject: [PATCH] gnu: tesseract-ocr: Update to 4.1.1)

* gnu/packages/ocr.scm (tesseract-ocr): Update to 4.1.1
---
 gnu/packages/ocr.scm | 53 +++++++++++++++++++++++++++++++++++++++-----
 1 file changed, 47 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..1ea7a94085 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,8 +27,17 @@ 
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages backup)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages icu4c)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages xml)
   #:use-module (gnu packages image))
 
 (define-public ocrad
@@ -52,25 +62,55 @@  it produces text in 8-bit or UTF-8 formats.")
     (license license:gpl3+)))
 
 (define-public tesseract-ocr
+  ;; some useful commits beyond last official stable release in release branch
+  (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df")
+        (revision "1"))
   (package
     (name "tesseract-ocr")
-    (version "3.04.01")
+    (version (git-version "4.1.1" revision commit))
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
               (url "https://github.com/tesseract-ocr/tesseract")
-              (commit version)))
+              (commit commit)
+              ;; source git repo with submodules; ensure they are fetched
+              (recursive? #t)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
+        (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
     (build-system gnu-build-system)
     (inputs
-     `(("leptonica" ,leptonica)))
+     `(  ("cairo" ,cairo)
+         ("icu" ,icu4c)
+         ("leptonica" ,leptonica)
+         ("pango" ,pango)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("autoconf-archive" ,autoconf-archive)
+       ("automake" ,automake)
+       ("googletest" ,googletest)
+       ("libarchive" ,libarchive)
+       ("libcurl" ,curl)
+       ("libtool" ,libtool)
+       ("libtiff" ,libtiff)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)
+       ("xsltproc" ,libxslt)))
     (arguments
      '(#:configure-flags
        (let ((leptonica (assoc-ref %build-inputs "leptonica")))
-         (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
+         (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'check)
+         (add-before 'build 'build-training
+           (lambda _
+             (invoke "make" "training")))
+         (add-after 'install 'install-training
+           (lambda _
+             (invoke "make" "training-install")
+             #t)))))
     (home-page "https://github.com/tesseract-ocr/tesseract")
     (synopsis "Optical character recognition engine")
     (description
@@ -79,7 +119,7 @@  high accuracy.  It supports many languages, output text formatting, hOCR
 positional information and page layout analysis.  Several image formats are
 supported through the Leptonica library.  It can also detect whether text is
 monospaced or proportional.")
-    (license license:asl2.0)))
+    (license license:asl2.0))))
 
 (define-public zinnia
   (let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
@@ -151,3 +191,4 @@  that allows us to create any hand-written recognition systems with low-cost.")
              #t)))))
     (inputs
      `(("zinnia" ,zinnia)))))
+
-- 
2.29.2