diff mbox series

[bug#59092] gnu: Add motif

Message ID CAJsg1E8oi47ChN0E5oCH-g09NJzchcN4imv0_XOMDaDeCZwF5Q@mail.gmail.com
State New
Headers show
Series [bug#59092] gnu: Add motif | expand

Commit Message

Andy Tai Jan. 10, 2023, 9:46 p.m. UTC
updated patch

Comments

Simon Tournier Jan. 11, 2023, 2:51 p.m. UTC | #1
Hi,

On mar., 10 janv. 2023 at 21:46, Andy Tai <atai@atai.org> wrote:

> From afd23adac9ba2165cc28afcc6b0de088c8b17dc2 Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Tue, 10 Jan 2023 21:42:15 +0000
> Subject: [PATCH] gnu: Add motif
>
> * gnu/packages/lesstif.scm (motif): New variable

Close because included with [PATCH v2] of #59093.

Cheers,
simon
diff mbox series

Patch

From afd23adac9ba2165cc28afcc6b0de088c8b17dc2 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Tue, 10 Jan 2023 21:42:15 +0000
Subject: [PATCH] gnu: Add motif

* gnu/packages/lesstif.scm (motif): New variable
---
 gnu/packages/lesstif.scm | 41 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..584c47a943 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +22,12 @@  (define-module (gnu packages lesstif)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix git-download)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages c)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xorg))
 
 
@@ -46,3 +53,37 @@  (define-public lesstif
     (synopsis "Clone of the Motif toolkit for the X window system")
     (description "Clone of the Motif toolkit for the X window system.")
     (license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+
+(define-public motif
+  (let ((commit   "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+        (revision "0"))
+      (package
+        (name "motif")
+        (version (git-version "2.3.8" revision commit))
+        (source
+          (origin
+            (method git-fetch)
+            (uri (git-reference
+                    (url "https://git.code.sf.net/p/motif/code")
+                    (commit commit)))
+               ;; 2.3.8 release plus unreleased bug fixes in master branch
+            (file-name (git-file-name name version))
+            (sha256
+              (base32
+                "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+        (build-system gnu-build-system)
+        (inputs
+          (list libx11 xorgproto))
+        (propagated-inputs
+          (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+        (native-inputs
+            (list autoconf automake byacc flex libtool pkg-config))
+        (home-page "https://motif.ics.com/motif")
+        (synopsis "Motif toolkit for the X window system")
+        (description "Motif is a standard graphical user interface, (as
+defined by the IEEE 1295 specification), used on more than 200 hardware and
+software platforms.  It provides application developers, end users, and system
+vendors with a widely used environment for standardizing
+application presentation on a wide range of platforms.")
+        (license license:lgpl2.1+))))
-- 
2.34.1