diff mbox series

[bug#59092] gnu: Add motif

Message ID CAJsg1E8bmAj1UGKAEUvVzNWdzszvrMHheZ5azrs5Yr2WQ7UX9A@mail.gmail.com
State New
Headers show
Series [bug#59092] gnu: Add motif | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Andy Tai Nov. 7, 2022, 5:02 a.m. UTC

Comments

Christopher Baines Nov. 17, 2022, 11:35 a.m. UTC | #1
Andy Tai <atai@atai.org> writes:

Subject: [PATCH] gnu: Add motif

> * gnu/packages/lesstif.scm (motif): New variable
> ---
>  gnu/packages/lesstif.scm | 40 +++++++++++++++++++++++++++++++++++++++-
>  1 file changed, 39 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
> index 8f017f41be..7a53c1a9ee 100644
> --- a/gnu/packages/lesstif.scm
> +++ b/gnu/packages/lesstif.scm
> @@ -1,5 +1,6 @@
>  ;;; GNU Guix --- Functional package management for GNU
>  ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
> +;;; Copyright © 2022 Andy Tai <atai@atai.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -21,7 +22,15 @@ (define-module (gnu packages lesstif)
>    #:use-module (guix packages)
>    #:use-module (guix download)
>    #:use-module (guix build-system gnu)
> -  #:use-module (gnu packages xorg))
> +  #:use-module (guix git-download)
> +  #:use-module (gnu packages autotools)
> +  #:use-module (gnu packages c)
> +  #:use-module (gnu packages flex)
> +  #:use-module (gnu packages fontutils)
> +  #:use-module (gnu packages pkg-config)
> +  #:use-module (gnu packages xorg)
> +
> +  )

There's a needless line here.

>  (define-public lesstif
> @@ -46,3 +55,32 @@ (define-public lesstif
>      (synopsis "Clone of the Motif toolkit for the X window system")
>      (description "Clone of the Motif toolkit for the X window system.")
>      (license license:gpl2+))) ; some files are lgpl2.1+ or x11
> +
> +
> +(define-public motif
> +  (let ((commit   "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
> +        (revision "0"))
> +      (package
> +        (name "motif")
> +        (version (git-version "2.3.8" revision commit))
> +        (source
> +          (origin
> +            (method git-fetch)
> +            (uri (git-reference
> +                    (url "https://git.code.sf.net/p/motif/code")
> +                    (commit commit)))
> +            (file-name (git-file-name name version))
> +            (sha256
> +              (base32
> +                "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
> +        (build-system gnu-build-system)
> +        (inputs
> +          (list libx11 xorgproto ))

I'd remove the space after xorgproto.

> +        (propagated-inputs
> +          (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
> +        (native-inputs
> +            (list autoconf automake byacc flex  libtool pkg-config))
> +        (home-page "https://motif.ics.com/motif")
> +        (synopsis "Motif toolkit for the X window system")
> +        (description "The Motif toolkit for the X window system.")

Would you be able to write a different description? It's nice if it
doesn't just repeat the synopsis.

Thanks,

Chris
diff mbox series

Patch

From fef78fc20a8599e87b8d12f674dedd7d1cfa3eed Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sun, 6 Nov 2022 20:56:05 -0800
Subject: [PATCH] gnu: Add motif

* gnu/packages/lesstif.scm (motif): New variable
---
 gnu/packages/lesstif.scm | 40 +++++++++++++++++++++++++++++++++++++++-
 1 file changed, 39 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..7a53c1a9ee 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,7 +22,15 @@  (define-module (gnu packages lesstif)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module (gnu packages xorg))
+  #:use-module (guix git-download)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages c)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages xorg)
+
+  )
 
 
 (define-public lesstif
@@ -46,3 +55,32 @@  (define-public lesstif
     (synopsis "Clone of the Motif toolkit for the X window system")
     (description "Clone of the Motif toolkit for the X window system.")
     (license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+
+(define-public motif
+  (let ((commit   "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+        (revision "0"))
+      (package
+        (name "motif")
+        (version (git-version "2.3.8" revision commit))
+        (source
+          (origin
+            (method git-fetch)
+            (uri (git-reference
+                    (url "https://git.code.sf.net/p/motif/code")
+                    (commit commit)))
+            (file-name (git-file-name name version))
+            (sha256
+              (base32
+                "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+        (build-system gnu-build-system)
+        (inputs
+          (list libx11 xorgproto ))
+        (propagated-inputs
+          (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+        (native-inputs
+            (list autoconf automake byacc flex  libtool pkg-config))
+        (home-page "https://motif.ics.com/motif")
+        (synopsis "Motif toolkit for the X window system")
+        (description "The Motif toolkit for the X window system.")
+        (license license:lgpl2.1+))))
-- 
2.38.0