diff mbox series

[bug#59829,core-updates] gnu: wlroots: Add propagated input xcb-util-renderutil

Message ID CAJsg1E8R14VGwoy6Lf=MO4BMYtCp44wETku5t8tEgksK_r2PXw@mail.gmail.com
State New
Headers show
Series [bug#59829,core-updates] gnu: wlroots: Add propagated input xcb-util-renderutil | expand

Commit Message

Andy Tai Dec. 5, 2022, 6:44 a.m. UTC

Comments

Simon Tournier Jan. 6, 2023, 11:53 a.m. UTC | #1
Hi,

On Sun, 04 Dec 2022 at 22:44, Andy Tai <lichengtai@gmail.com> wrote:

> gnu/packages/wm.scm (wlroots): Add propagated input xcb-util-renderutil

Could you explain why this propagation is required?  Because propagation
should be avoid at first and it should be used when no other option are
possible, IMHO.


Cheers,
simon
Andy Tai Jan. 7, 2023, 7:13 a.m. UTC | #2
Hi, I thought propagation inputs are for letting dependent packages to be
able to automatically add this input to its dependency list, like, say,
glib as a propagation input for gtk+ as all gtk+ [programs has glib as an
input or dependency.  xcb-util-renderutil seems to have a similar role for
wlroots.

If this is not correct, please file a patch to change it, and merge it.

On Fri, Jan 6, 2023 at 4:07 AM zimoun <zimon.toutoune@gmail.com> wrote:

> Hi,
>
> On Sun, 04 Dec 2022 at 22:44, Andy Tai <lichengtai@gmail.com> wrote:
>
> > gnu/packages/wm.scm (wlroots): Add propagated input xcb-util-renderutil
>
> Could you explain why this propagation is required?  Because propagation
> should be avoid at first and it should be used when no other option are
> possible, IMHO.
>
>
> Cheers,
> simon
>
Simon Tournier Jan. 9, 2023, 10:20 a.m. UTC | #3
Hi,

On ven., 06 janv. 2023 at 23:13, Andy Tai <lichengtai@gmail.com> wrote:

> Hi, I thought propagation inputs are for letting dependent packages to be
> able to automatically add this input to its dependency list, like, say,
> glib as a propagation input for gtk+ as all gtk+ [programs has glib as an
> input or dependency.  xcb-util-renderutil seems to have a similar role for
> wlroots.

The manual [1] reads for propagated-inputs:

        Lastly, propagated-inputs is similar to inputs, but the
        specified packages will be automatically installed to profiles
        (see the role of profiles in Guix) alongside the package they
        belong to (see guix package, for information on how guix package
        deals with propagated inputs).

        For example this is necessary when packaging a C/C++ library
        that needs headers of another library to compile, or when a
        pkg-config file refers to another one via its Requires field.

        Another example where propagated-inputs is useful is for
        languages that lack a facility to record the run-time search
        path akin to the RUNPATH of ELF files; this includes Guile,
        Python, Perl, and more. When packaging libraries written in
        those languages, ensure they can find library code they depend
        on at run time by listing run-time dependencies in
        propagated-inputs rather than inputs.


Other said, a dependency is added to the propagated-inputs list when
Guix is not able to automatically determine if the package references a
dependency from the inputs list.

My naive question is: is xcb-util-renderutil required by wlroots to
correctly run?

1: <https://guix.gnu.org/manual/devel/en/guix.html#package_002dpropagated_002dinputs>


Cheers,
simon
Andy Tai Jan. 11, 2023, 8:18 a.m. UTC | #4
I added it for XWayland, which requires this if XWayland support is
included in wlroots, which I believe shall be there.

On Mon, Jan 9, 2023 at 4:20 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
>
>
> My naive question is: is xcb-util-renderutil required by wlroots to
> correctly run?
>
>
Maxim Cournoyer Jan. 16, 2023, 3:01 p.m. UTC | #5
Hi Andy,

Andy Tai <lichengtai@gmail.com> writes:

> I added it for XWayland, which requires this if XWayland support is
> included in wlroots, which I believe shall be there.

It's good to know the reason behind the change, but as Simon said for
propagated inputs, we need a clear, exact understanding of why it is so,
as it's otherwise preferred to simple use simple inputs, and sometimes
wrapping.

Valid reasons currently include: references in public headers or
mentioned in Requires* in pkg-config files (those ending in '.pc'), or
for languages such as Python that lack a way to register dependencies in
binaries like C or C++ can (via RUNPATH in elf).

Can you spot which of the above it is?
Andy Tai Jan. 16, 2023, 9:34 p.m. UTC | #6
hi, I will update the patch moving xcb-util-renderutil to inputs....
that will probably be safer.

On Mon, Jan 16, 2023 at 7:01 AM Maxim Cournoyer
<maxim.cournoyer@gmail.com> wrote:
>
> Hi Andy,
>
> Andy Tai <lichengtai@gmail.com> writes:
>
> > I added it for XWayland, which requires this if XWayland support is
> > included in wlroots, which I believe shall be there.
>
> It's good to know the reason behind the change, but as Simon said for
> propagated inputs, we need a clear, exact understanding of why it is so,
> as it's otherwise preferred to simple use simple inputs, and sometimes
> wrapping.
>
> Valid reasons currently include: references in public headers or
> mentioned in Requires* in pkg-config files (those ending in '.pc'), or
> for languages such as Python that lack a way to register dependencies in
> binaries like C or C++ can (via RUNPATH in elf).
>
> Can you spot which of the above it is?
>
> --
> Thanks,
> Maxim
diff mbox series

Patch

From dc2194ff0b61e0e4b13953189abc2a847240ce1f Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sun, 4 Dec 2022 22:31:32 -0800
Subject: [PATCH] gnu: wlroots: Add propagated input xcb-util-renderutil

gnu/packages/wm.scm (wlroots): Add propagated input xcb-util-renderutil
---
 gnu/packages/wm.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 201c5994d8..890d51b957 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1566,6 +1566,7 @@  (define-public wlroots
            wayland
            wayland-protocols
            xcb-util-errors
+           xcb-util-renderutil
            xcb-util-wm
            xorg-server-xwayland))
     (native-inputs
-- 
2.38.1