diff mbox series

[bug#46376] gnu: tesseract-ocr: update to 4.1.1)

Message ID CAJsg1E8Md0KGfH0RHRVrWCVuw7kzwYT2yA9ZOuCWQ1GpzaeBnw@mail.gmail.com
State Accepted
Headers show
Series [bug#46376] gnu: tesseract-ocr: update to 4.1.1) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andy Tai Feb. 8, 2021, 6:51 a.m. UTC
* gnu/packages/ocr.scm (tesseract-ocr): update to 4.1.1
---
 gnu/packages/ocr.scm | 36 +++++++++++++++++++++++++++++-------
 1 file changed, 29 insertions(+), 7 deletions(-)

   (let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")

Comments

Jelle Licht Feb. 8, 2021, 9:36 p.m. UTC | #1
Hello Andy,

Thanks for working on this package! I was not able to cleanly apply any
of the patches, but that problem might be on my end though.

Something did seem to go wrong though, as I notice three patches that do
the same (from a quick glance).

I have some nitpicks, some of them more serious than others;

Andy Tai <atai@atai.org> writes:

> * gnu/packages/ocr.scm (tesseract-ocr): update to 4.1.1
                                          ^ This is usually capitalised.
> [snip]
>  (define-public tesseract-ocr
> +  ;; some useful commits beyond last official stable release in release branch
> +  (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df"))
>    (package
>      (name "tesseract-ocr")
> -    (version "3.04.01")
> +    (version "4.1.1")
                ^ Since we are not _actually_ using version 4.1.1, but a
                  later commit, you could use
                  `(git-version "4.1.1" revision commit)' here instead


>      (source
>       (origin
>         (method git-fetch)
>         (uri (git-reference
>                (url "https://github.com/tesseract-ocr/tesseract")
> -              (commit version)))
> -       (file-name (git-file-name name version))
> +              (commit commit)
> +              ;; Fetch git submodules
> +              (recursive? #t)))

Instead of stating what the code does, would you consider adding a
comment why this is needed?

> +       (file-name (string-append name "-" version "-" commit "-checkout"))
                     ^ You can use `(git-file-name name version)' here.

>         (sha256
> -        (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
> +        (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
>      (build-system gnu-build-system)
>      (inputs
> -     `(("leptonica" ,leptonica)))
> +     `(  ("cairo" ,cairo)
> +         ("icu" ,icu4c)
> +         ("leptonica" ,leptonica)
> +         ("pango" ,pango)))
> +    (native-inputs
> +     `(("autoconf" ,autoconf)
> +       ("autoconf-archive" ,autoconf-archive)
> +       ("automake" ,automake)
> +       ("googletest" ,googletest)
> +       ("libtool" ,libtool)
> +       ("pkg-config" ,pkg-config)))
>      (arguments
>       '(#:configure-flags
>         (let ((leptonica (assoc-ref %build-inputs "leptonica")))
> -         (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
> +         (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
> +       ;; some test, applybox_test fails to build
> +       #:tests? #f))
 2 nits: Is it possible to patch or disable only the failing tests?
 Is there a reason googletest is added if testing is subsequently disabled?

Thanks,
 - Jelle
diff mbox series

Patch

diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..b666ec5aab 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,7 +27,12 @@ 
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages icu4c)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages image))

@@ -52,25 +58,41 @@  it produces text in 8-bit or UTF-8 formats.")
     (license license:gpl3+)))

 (define-public tesseract-ocr
+  ;; some useful commits beyond last official stable release in release branch
+  (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df"))
   (package
     (name "tesseract-ocr")
-    (version "3.04.01")
+    (version "4.1.1")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
               (url "https://github.com/tesseract-ocr/tesseract")
-              (commit version)))
-       (file-name (git-file-name name version))
+              (commit commit)
+              ;; Fetch git submodules
+              (recursive? #t)))
+       (file-name (string-append name "-" version "-" commit "-checkout"))
        (sha256
-        (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
+        (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
     (build-system gnu-build-system)
     (inputs
-     `(("leptonica" ,leptonica)))
+     `(  ("cairo" ,cairo)
+         ("icu" ,icu4c)
+         ("leptonica" ,leptonica)
+         ("pango" ,pango)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("autoconf-archive" ,autoconf-archive)
+       ("automake" ,automake)
+       ("googletest" ,googletest)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
     (arguments
      '(#:configure-flags
        (let ((leptonica (assoc-ref %build-inputs "leptonica")))
-         (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
+         (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
+       ;; some test, applybox_test fails to build
+       #:tests? #f))
     (home-page "https://github.com/tesseract-ocr/tesseract")
     (synopsis "Optical character recognition engine")
     (description
@@ -79,7 +101,7 @@  high accuracy.  It supports many languages, output
text formatting, hOCR
 positional information and page layout analysis.  Several image formats are
 supported through the Leptonica library.  It can also detect whether text is
 monospaced or proportional.")
-    (license license:asl2.0)))
+    (license license:asl2.0))))

 (define-public zinnia