diff mbox series

[bug#50054] Acknowledgement ([PATCH] gnu: Add bgfx)

Message ID CAJsg1E-wuXM+GKTHX9csGDHFtGFSD=qLGwLTnhE3gHUL9RhX=w@mail.gmail.com
State New
Headers show
Series [bug#50054] Acknowledgement ([PATCH] gnu: Add bgfx) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andy Tai Aug. 14, 2021, 8:51 a.m. UTC
On Sat, Aug 14, 2021 at 1:37 AM GNU bug Tracking System
<help-debbugs@gnu.org> wrote:
>
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 50054@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 50054: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=50054
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
diff mbox series

Patch

From 998232936a491ace0383fbcff968029a81c12c1e Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sat, 14 Aug 2021 01:31:34 -0700
Subject: [PATCH] gnu: Add bgfx
To: guix-patches@gnu.org

* gnu/packages/graphics.scm (bgfx): New variable
---
 gnu/packages/graphics.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 38feb27c87..a07c3067fb 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2000,3 +2000,41 @@  Some feature highlights:
 such as VR and AR on mobile, PC/desktop, and any other device.  Monado aims to be
 a complete and conforming implementation of the OpenXR API made by Khronos.")
     (license license:boost1.0)))
+
+(define-public bgfx
+  (let ((commit "65513d08541ab1ead814f2c97d0502c8d13eae68")
+        (revision "0"))
+    (package
+      (name "bgfx")
+      (version
+       (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/bkaradzic/bgfx.cmake")
+           (commit commit)
+           ;; Fetch git submodules
+           (recursive? #t)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1k18230zw3v2l0vgz5xi0l23fa0686yx0jd6hkvvvwp3zlakqp7n"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:tests? #f)) ;; no tests
+      (inputs
+       `(("glslang" ,glslang)
+         ("libxcb" ,libxcb)
+         ("opengl" ,mesa)
+         ("vulkan-loader" ,vulkan-loader)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)
+         ("vulkan-headers" ,vulkan-headers)))
+      (home-page "https://github.com/bkaradzic/bgfx")
+      (synopsis  "Cross-platform, graphics API agnostic. rendering library")
+      (description "bgfx is a cross-platform, graphics API agnostic,
+'Bring Your Own Engine/Framework' style rendering library supporting Direct3D,
+OpenGL, Metal, Vulkan and WebGL.")
+      (license (list license:bsd-2 license:cc0)))))
-- 
2.32.0