diff mbox series

[bug#61010] gnu: Add icewm

Message ID CAJsg1E-q0cRtAyB6Zw0MicWE1HxgAbjmgoz58fgMzPzYvwfz_Q@mail.gmail.com
State New
Headers show
Series [bug#61010] gnu: Add icewm | expand

Commit Message

Andy Tai Jan. 25, 2023, 7:50 a.m. UTC
same patch with only difference of label as "v2"

not sure how to make Guix QA rebuild with the new patch

On Tue, Jan 24, 2023 at 11:37 PM Andy Tai <atai@atai.org> wrote:
>
> updated patch  attached
>
>
> On Tue, Jan 24, 2023 at 4:35 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
> >
> > The patch builds fine and it LTGM except one minor point.
> >
> > On dim., 22 janv. 2023 at 12:37, Andy Tai <atai@atai.org> wrote:
> >
> > This archive contains generated .gmo which are not in the source code
> > [1] and I do not know what is the usual Guix policy about that.  Do we
> > re-generate them?
> >
> > Other said, these files are in the archive tar.gz [2].
> >
> > 1: <https://github.com/ice-wm/icewm/tree/3.3.1/po>
> > 2: <https://github.com/ice-wm/icewm/archive/refs/tags/3.3.1.tar.gz>
> >
>
> This I did not address in the revision because the second .tar.gz is
> available on the net, satisfying GPL's source requirement... but will
> revise if Guix policy demands otherwise
> >
> > > \ No newline at end of file
> >
> > This patch does not apply to current master.  From my point of view, it
> > is worth to provide the base-commit (see --base option of
> > git-format-patch or git-send-email).
> >
> > And it helps if the new package is not added to the end of the file.
> > For instance, I would put it between i3lock-fancy and xmonad-next.
> >
>
> addressed as suggested
> >
> > Cheers,
> > simon
diff mbox series

Patch

From 58af949be6d43c4194c517874a021b43cbea1547 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Tue, 24 Jan 2023 23:25:07 -0800
Subject: [PATCH v2] gnu: Add icewm

* gnu/packages/wm.scm (icewm): New variable
---
 gnu/packages/wm.scm | 59 +++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a860ed1f93..f2d3f6f1b3 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -100,6 +100,7 @@  (define-module (gnu packages wm)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages calendar)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages check)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages docbook)
@@ -763,6 +764,64 @@  (define-public i3lock-fancy
 desktop environment.")
     (license license:expat)))
 
+(define-public icewm
+  (package
+    (name "icewm")
+    (version "3.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/ice-wm/icewm/releases/download/"
+                    version "/icewm-" version ".tar.lz"))
+              (sha256
+               (base32
+                "14vkv5r9rvwfj8gmdsrkkq7vxvk2j7z7wfybzc8ywj469yya5ppq"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list fontconfig
+                  fribidi
+                  imlib2
+                  libice
+                  libjpeg-turbo
+                  libsm
+                  libxcomposite
+                  libxdamage
+                  libxext
+                  libxfixes
+                  libxft
+                  libxinerama
+                  libxpm
+                  libxrandr
+                  libxrender
+                  libx11
+                  lzip
+                  perl))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'skip-failing-test
+                    ;; strtest.cc tests failing due to $HOME and /etc setup
+                    ;; difference under guix
+                    (lambda _
+                      (substitute* "src/Makefile.in"
+                        (("TESTS = strtest\\$\\(EXEEXT\\)")
+                         "TESTS = ")) #t)))))
+    (home-page "https://ice-wm.org/")
+    (synopsis "Window manager for the X Window System")
+    (description
+     "IceWM is a window manager for the X Window System.  The goal of
+IceWM is speed, simplicity, and not getting in the user’s way.  It comes with a
+taskbar with pager, global and per-window keybindings and a dynamic menu system.
+Application windows can be managed by keyboard and mouse.  Windows
+can be iconified to the taskbar, to the tray, to the desktop or be made
+hidden.  They are controllable by a quick switch window (Alt+Tab) and in a
+window list.  A handful of configurable focus models are
+menu-selectable.  Setups with multiple monitors are supported by RandR and
+Xinerama.  IceWM is very configurable, themeable and well documented.  It
+includes an optional external background wallpaper manager with transparency
+support, a simple session manager and a system tray.")
+    (license license:gpl2)))
+
+
 (define-public xmonad-next
   (package
     (name "xmonad-next")

base-commit: 718223c58c20fa066527fb30da2b5dccca82913f
-- 
2.39.1