diff mbox series

[bug#52233] gnu: godot: Update to 3.4

Message ID CAJsg1E-216thCMqyPXOFedvA0EGFHYri1=vZ8PXa61Qj9a=Zzg@mail.gmail.com
State Accepted
Headers show
Series [bug#52233] gnu: godot: Update to 3.4 | expand

Commit Message

Andy Tai Dec. 9, 2021, 11:14 p.m. UTC
with the attached patch to superstarfighter, which updates it to the
next version (master tip), the game can run, with audio.

What should I do now?   with these two patches but the issue is marked
"done", do I have to file two new issues for these two patches?   Help
to make this submission easier highly appreciated.

On Sun, Dec 5, 2021 at 11:27 PM Andy Tai <atai@atai.org> wrote:
>
> updated patch:
>
> godot built from this can run the master tip of the superstarfighter
> git (checked out by itself) successfully
>
> However  the superstarfighter in guix still aborts.
>
> So that still needs more investigation as to what is going on there.
>
> I am using Fedora as the host OS, with guix on it.
>
>
> On Thu, Dec 2, 2021 at 11:25 AM Leo Famulari <leo@famulari.name> wrote:
> >
> > On Thu, Dec 02, 2021 at 12:07:34AM -0800, Andy Tai wrote:
> > > I just built  superstarfighter with godot 3.4 and I was able to start
> > > the game on my PC.  So I guess it may run successfully or fail due to
> > > difference in hardware configurations.  Just a data point.
> >
> > I'm curious, was that on Guix System? Or Guix on another distro? I
> > tested with Guix on Debian.

Comments

Leo Famulari Dec. 10, 2021, 6:57 a.m. UTC | #1
On Thu, Dec 09, 2021 at 03:14:20PM -0800, Andy Tai wrote:
> with the attached patch to superstarfighter, which updates it to the
> next version (master tip), the game can run, with audio.

Thanks!

> What should I do now?   with these two patches but the issue is marked
> "done", do I have to file two new issues for these two patches?   Help
> to make this submission easier highly appreciated.

The issue is marked "done" because we keep sending messages to
<52233-done@debbugs.gnu.org>, which is how you close a ticket with
debbugs.

I've manually reopened this ticket several times but we keep closing it
accidentally.
Leo Famulari Dec. 10, 2021, 4:21 p.m. UTC | #2
On Thu, Dec 09, 2021 at 03:14:20PM -0800, Andy Tai wrote:
> with the attached patch to superstarfighter, which updates it to the
> next version (master tip), the game can run, with audio.

Thanks! I tweaked your update to be a little simpler and pushed it along
with the Godot update as af067eaff4220ea1e86099894087b619606010b2
Andy Tai Dec. 10, 2021, 5:49 p.m. UTC | #3
Thank you. done for real this time

On Fri, Dec 10, 2021 at 8:21 AM Leo Famulari <leo@famulari.name> wrote:
>
> On Thu, Dec 09, 2021 at 03:14:20PM -0800, Andy Tai wrote:
> > with the attached patch to superstarfighter, which updates it to the
> > next version (master tip), the game can run, with audio.
>
> Thanks! I tweaked your update to be a little simpler and pushed it along
> with the Godot update as af067eaff4220ea1e86099894087b619606010b2
diff mbox series

Patch

From 1b9a3128693d7fe2604643f20a844897cb10e7a0 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Thu, 9 Dec 2021 15:08:33 -0800
Subject: [PATCH] gnu: superstarfighter: Update to 0.6.5.
To: guix-patches@gnu.org

* gnu/packages/games.scm (superstarfighter): Update to 0.6.5.
---
 gnu/packages/games.scm | 143 +++++++++++++++++++++--------------------
 1 file changed, 72 insertions(+), 71 deletions(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 819a832baf..ec8a2e024c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2582,81 +2582,82 @@  (define-public solarus-quest-editor
 modify quests for the Solarus engine.")))
 
 (define-public superstarfighter
-  (package
-    (name "superstarfighter")
-    (version "0.6.4")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/notapixelstudio/superstarfighter")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1fly63yf5ls1xwm15if4lxwy67wi84k4gvjllljpykrl18vw2y0y"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:tests? #f                      ;there are no tests
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda _
-             (chdir "godot")
-             (setenv "HOME" (getcwd))
-             (with-output-to-file "export_presets.cfg"
-               (lambda ()
-                 (display
-                  "[preset.0]
+  (let ((commit "32521f467616bb390e3929d07e1936ff43fe64da"))
+      (package
+        (name "superstarfighter")
+        (version "0.6.5")
+        (source
+         (origin
+           (method git-fetch)
+           (uri (git-reference
+                 (url "https://github.com/notapixelstudio/superstarfighter")
+                 (commit commit)))
+           (file-name (string-append name "-" version "-" commit "-checkout"))
+           (sha256
+            (base32 "1ckghzrfgvk9z1n5f4ivnamm6s8h9sbv0a3aq9pp4a3yrhkgld0k"))))
+        (build-system gnu-build-system)
+        (arguments
+         `(#:tests? #f                      ;there are no tests
+           #:phases
+           (modify-phases %standard-phases
+             (replace 'configure
+               (lambda _
+                 (chdir "godot")
+                 (setenv "HOME" (getcwd))
+                 (with-output-to-file "export_presets.cfg"
+                   (lambda ()
+                     (display
+                      "[preset.0]
 name=\"Guix\"
 platform=\"Linux/X11\"
 runnable=true
 [preset.0.options]")))
-             #t))
-         (replace 'build
-           (lambda _
-             (let ((godot (assoc-ref %build-inputs "godot-headless")))
-               (invoke (string-append godot "/bin/godot_server")
-                       "--export-pack" "Guix"
-                       "superstarfighter.pck" "project.godot"))
-             #t))
-         (replace 'install
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin"))
-                    (share (string-append out "/share"))
-                    (data (string-append share "/superstarfighter"))
-                    (icons (string-append share "/icons/hicolor/256x256/apps")))
-               (install-file "superstarfighter.pck" data)
-               (mkdir-p bin)
-               (call-with-output-file (string-append bin "/superstarfighter")
-                 (lambda (port)
-                   (format port
-                           "#!/bin/sh~@
-                            exec ~a/bin/godot --main-pack ~a/superstarfighter.pck~%"
-                           (assoc-ref inputs "godot")
-                           data)
-                   (chmod port #o755)))
-               (mkdir-p icons)
-               (copy-file "icon.png" (string-append icons "/" ,name ".png"))
-               (make-desktop-entry-file
-                (string-append share "/applications/" ,name ".desktop")
-                #:name "SuperStarfighter"
-                #:comment "Fast-paced arcade combat game"
-                #:exec ,name
-                #:icon ,name
-                #:categories '("Game" "ArcadeGame")))
-             #t)))))
-    (native-inputs
-     `(("godot-headless" ,godot "headless")))
-    (inputs
-     `(("godot" ,godot)))
-    (home-page "https://notapixel.itch.io/superstarfighter")
-    (synopsis "Fast-paced local multiplayer arcade game")
-    (description "In SuperStarfighter, up to four local players compete in a
-2D arena with fast-moving ships and missiles.  Different game types are
-available, as well as a single-player mode with AI-controlled ships.")
-    (license (list license:expat         ; game
-                   license:silofl1.1)))) ; fonts
+                 #t))
+             (replace 'build
+               (lambda _
+                 (let ((godot (assoc-ref %build-inputs "godot-headless")))
+                   (invoke (string-append godot "/bin/godot_server")
+                           "--export-pack" "Guix"
+                           "superstarfighter.pck" "project.godot"))
+                 #t))
+             (replace 'install
+               (lambda* (#:key inputs outputs #:allow-other-keys)
+                 (let* ((out (assoc-ref outputs "out"))
+                        (bin (string-append out "/bin"))
+                        (share (string-append out "/share"))
+                        (data (string-append share "/superstarfighter"))
+                        (icons (string-append share "/icons/hicolor/256x256/apps")))
+                   (install-file "superstarfighter.pck" data)
+                   (mkdir-p bin)
+                   (call-with-output-file (string-append bin "/superstarfighter")
+                     (lambda (port)
+                       (format port
+                               "#!/bin/sh~@
+                                exec ~a/bin/godot --main-pack ~a/superstarfighter.pck~%"
+                               (assoc-ref inputs "godot")
+                               data)
+                       (chmod port #o755)))
+                   (mkdir-p icons)
+                   (copy-file "icon.png" (string-append icons "/" ,name ".png"))
+                   (make-desktop-entry-file
+                    (string-append share "/applications/" ,name ".desktop")
+                    #:name "SuperStarfighter"
+                    #:comment "Fast-paced arcade combat game"
+                    #:exec ,name
+                    #:icon ,name
+                    #:categories '("Game" "ArcadeGame")))
+                 #t)))))
+        (native-inputs
+         `(("godot-headless" ,godot "headless")))
+        (inputs
+         `(("godot" ,godot)))
+        (home-page "https://notapixel.itch.io/superstarfighter")
+        (synopsis "Fast-paced local multiplayer arcade game")
+        (description "In SuperStarfighter, up to four local players compete in a
+    2D arena with fast-moving ships and missiles.  Different game types are
+    available, as well as a single-player mode with AI-controlled ships.")
+        (license (list license:expat         ; game
+                       license:silofl1.1))))) ; fonts
 
 (define %ufoai-commit "a542a87a891f96b1ab2c44d35b2f6f16859a5019")
 (define %ufoai-revision "0")

base-commit: 4665e6a73b233e3755ffbba7ecfdbbb53dae87bd
-- 
2.34.0