diff mbox series

[bug#59092] updated patch

Message ID CAJsg1E-1+GcUh_4dmb5Fy+tLrorCWzgHtNNAVMxcczAtzhZJaA@mail.gmail.com
State New
Headers show
Series [bug#59092] updated patch | expand

Commit Message

Andy Tai Dec. 23, 2022, 6:34 a.m. UTC
comments addressed

Comments

Simon Tournier Jan. 9, 2023, 12:19 p.m. UTC | #1
Hi,

The recipe LGTM but

 1. I have not tried to build it,
 2. I have not given a quick look to the source.
 

On jeu., 22 déc. 2022 at 22:34, Andy Tai <lichengtai@gmail.com> wrote:
> +(define-public motif
> +  (let ((commit   "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
> +        (revision "0"))
> +      (package
> +        (name "motif")
> +        (version (git-version "2.3.8" revision commit))

Maybe it could helpful for later update to mention with a comment why
this commit is required and the release version is not enough.

> +        (source
> +          (origin
> +            (method git-fetch)
> +            (uri (git-reference
> +                    (url "https://git.code.sf.net/p/motif/code")
> +                    (commit commit)))
> +            (file-name (git-file-name name version))
> +            (sha256
> +              (base32
> +                "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
> +        (build-system gnu-build-system)
> +        (inputs
> +          (list libx11 xorgproto))
> +        (propagated-inputs
> +          (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
> +        (native-inputs
> +            (list autoconf automake byacc flex  libtool pkg-config))
                                                --^
                                       Extra space

Here, an extra space. :-)

> +        (home-page "https://motif.ics.com/motif")
> +        (synopsis "Motif toolkit for the X window system")
> +        (description "Motif is the industry standard graphical user interface, (as

Usually, we try to avoid such “the industry” and instead only “Motif is
a standard graphical user interface, …”

And the linter [1] complains about «description Validate package
descriptions sentences in description should be followed by two spaces;
possible infractions at 155, 343».

1: <https://qa.guix.gnu.org/issue/59092>

Cheers,
simon
Andy Tai Jan. 10, 2023, 8:35 p.m. UTC | #2
Thanks for the review.  The "industry standard" wording was copied
from the upstream description.  Unsure of what is Guix's policy of
using upstream wordings as they are or these should be changed per our
opinion.  In this case I will follow your suggestion

On Mon, Jan 9, 2023 at 4:20 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
>
>
> > +        (home-page "https://motif.ics.com/motif")
> > +        (synopsis "Motif toolkit for the X window system")
> > +        (description "Motif is the industry standard graphical user interface, (as
>
> Usually, we try to avoid such “the industry” and instead only “Motif is
> a standard graphical user interface, …”
>
diff mbox series

Patch

From 0c04d4eb75d7629766fed009d7e2e7d9faf01b1c Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Thu, 22 Dec 2022 22:30:33 -0800
Subject: [PATCH] gnu: Add motif

* gnu/packages/lesstif.scm (motif): New variable
---
 gnu/packages/lesstif.scm | 41 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..7aaad411a1 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +22,12 @@  (define-module (gnu packages lesstif)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix git-download)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages c)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xorg))
 
 
@@ -46,3 +53,37 @@  (define-public lesstif
     (synopsis "Clone of the Motif toolkit for the X window system")
     (description "Clone of the Motif toolkit for the X window system.")
     (license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+
+(define-public motif
+  (let ((commit   "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+        (revision "0"))
+      (package
+        (name "motif")
+        (version (git-version "2.3.8" revision commit))
+        (source
+          (origin
+            (method git-fetch)
+            (uri (git-reference
+                    (url "https://git.code.sf.net/p/motif/code")
+                    (commit commit)))
+            (file-name (git-file-name name version))
+            (sha256
+              (base32
+                "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+        (build-system gnu-build-system)
+        (inputs
+          (list libx11 xorgproto))
+        (propagated-inputs
+          (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+        (native-inputs
+            (list autoconf automake byacc flex  libtool pkg-config))
+        (home-page "https://motif.ics.com/motif")
+        (synopsis "Motif toolkit for the X window system")
+        (description "Motif is the industry standard graphical user interface, (as
+defined by the IEEE 1295 specification), used on more than 200 hardware and
+software platforms. It provides application developers, end users, and system
+vendors with the industry's most widely used environment for standardizing
+application presentation on a wide range of platforms. Motif is the leading
+user interface for the UNIX operating system.")
+        (license license:lgpl2.1+))))
-- 
2.38.1