diff mbox series

[bug#57597] Fwd: [PATCH] gnu: Add go-github-com-goccy-go-json.

Message ID CAJpP0NMBcjj9EL-myCzRJMco=fVrP-n9WqSETfV_nHt+teJV-A@mail.gmail.com
State Accepted
Headers show
Series [bug#57597] Fwd: [PATCH] gnu: Add go-github-com-goccy-go-json. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur Sept. 5, 2022, 1:34 p.m. UTC
---------- Forwarded message ---------
От: Adam Kandur <> <kefironpremise@gmail.com>
Date: сб, 3 сент. 2022 г. в 06:04
Subject: [PATCH] gnu: Add go-github-com-goccy-go-json.
To: <guix-patches@gnu.org>


* gnu/packages/golang.scm (go-github-com-goccy-go-json): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

--
2.37.2

Comments

Christopher Baines Sept. 10, 2022, 10:47 a.m. UTC | #1
Adam Kandur <kefironpremise@gmail.com> writes:

> * gnu/packages/golang.scm (go-github-com-goccy-go-json): New variable.
> ---
>  gnu/packages/golang.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)

Thanks Adam, I've pushed this to master as
fe42befd64df016d755f56107a407f5e4b5c3814.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 383d4d1..88bbd81 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2923,6 +2923,28 @@  (define-public go-github-com-burntsushi-toml
 is similar to Go's standard library @code{json} and @code{xml} package.")
     (license license:expat)))

+(define-public go-github-com-goccy-go-json
+  (package
+    (name "go-github-com-goccy-go-json")
+    (version "0.9.10")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/goccy/go-json")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1bg8p4c6r8r0kixdxv2m8xmdsmb1zl5sd8czswpccldjk3c358wp"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/goccy/go-json"))
+    (home-page "https://github.com/goccy/go-json")
+    (synopsis "JSON encoder/decoder in Go")
+    (description
+     "Fast JSON encoder/decoder compatible with encoding/json for Go.")
+    (license license:expat)))
+
 (define-public go-github-com-getsentry-raven-go
   (let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
         (revision "0"))