diff mbox series

[bug#57126,v2] gnu: Add espeakup.

Message ID CAJ1hvUF4H4LeGvTQ7Mz43nDSO-UhDDit8Cm2X4Vsx2U3s-TO3w@mail.gmail.com
State Accepted
Headers show
Series [bug#57126,v2] gnu: Add espeakup. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hunter Jozwiak Aug. 12, 2022, 3:39 a.m. UTC
From: Hunter Jozwiak <hunter.t.joz@gmail.com>

* gnu/packages/accessibility.scm (espeakup): New variable.
---
Fixes a bunch of problems that I didn't catch the first time around,
namely the copyright symbols being replaced with question marks. Also
moves the package definition to the end of the file.
 gnu/packages/accessibility.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Björn Höfling Sept. 21, 2022, 11:33 a.m. UTC | #1
Hi Hunter,

On Thu, 11 Aug 2022 20:39:13 -0700
hunter.t.joz@gmail.com wrote:

> From: Hunter Jozwiak <hunter.t.joz@gmail.com>
> 
> * gnu/packages/accessibility.scm (espeakup): New variable.
> ---
> Fixes a bunch of problems that I didn't catch the first time around,
> namely the copyright symbols being replaced with question marks. Also
> moves the package definition to the end of the file.

Thanks for recognizing this yourself. I pushed this as commit

e883ea89c6fa409634ed141bcbef9b39166067f9

with some minor changes (see below).

Of cause, this adds only the package to Guix, it does not create any
service for Guix System.

Björn


Changed:

 ;;; Copyright © 2018, 2021, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Andrew Miloradovsky <andrew@interpretmath.pw>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.
+;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -336,10 +336,10 @@ (define-public espeakup
     (native-inputs (list pkg-config))
     (inputs (list espeak-ng alsa-lib))
     (license license:gpl3+)
-    (synopsis "A bridge for espeak and speakup")
+    (synopsis "Bridge for espeak and speakup")
     (description
      "Espeakup is a bridge between the speakup driver implemented in
-the Linux kernel and the espeak-ng text to synthesizer.
+the Linux kernel and the espeak-ng text to speach synthesizer.
 In order for this package to work, you need to have the following
 kernel modules built:
 @itemize @bullet
@@ -348,4 +348,4 @@ (define-public espeakup
 @item
 CONFIG_SPEAKUP_SOFT=m
 @end itemize")
-    (home-page "https://github.com/williamh/espeakup")))
+    (home-page "ttps://github.com/linux-speakup/espeakup")))
diff mbox series

Patch

diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index 22e70b737a..43e0aa9998 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2018, 2021, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Andrew Miloradovsky <andrew@interpretmath.pw>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -28,6 +29,7 @@  (define-module (gnu packages accessibility)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
+  #:use-module (guix build-system meson)
   #:use-module (gnu packages)
   #:use-module (gnu packages lisp)
   #:use-module (gnu packages ocaml)
@@ -316,3 +318,34 @@  (define-public xmagnify
 assistant for graphic designers, who need to select individual pixels.")
     ;; Licensed either under Expat or GPLv2+.
     (license (list license:expat license:gpl2+))))
+
+(define-public espeakup
+  (package
+    (name "espeakup")
+    (version "0.90")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/linux-speakup/espeakup")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0lmjwafvfxy07zn18v3dzjwwpnid2xffgvy2dzlwkbns8gb60ds2"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list espeak-ng alsa-lib))
+    (license license:gpl3+)
+    (synopsis "A bridge for espeak and speakup")
+    (description
+     "Espeakup is a bridge between the speakup driver implemented in
+the Linux kernel and the espeak-ng text to synthesizer.
+In order for this package to work, you need to have the following
+kernel modules built:
+@itemize @bullet
+@item
+CONFIG_SPEAKUP=m
+@item
+CONFIG_SPEAKUP_SOFT=m
+@end itemize")
+    (home-page "https://github.com/williamh/espeakup")))