diff mbox series

[bug#58356] Add xtrlock

Message ID CAHHeYz+6XjU1YVCZJBsQ1KindfOHhLSDPH6LHPFd4qw4RWdbYA@mail.gmail.com
State New
Headers show
Series [bug#58356] Add xtrlock | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Mehmet Tekman Oct. 7, 2022, 2:01 p.m. UTC
---
 gnu/packages/xtrlock.scm | 71 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 71 insertions(+)
 create mode 100644 gnu/packages/xtrlock.scm

+anything that has been entered.")
+      (license license:gpl3))))

Comments

Maxim Cournoyer Oct. 8, 2022, 5:08 a.m. UTC | #1
Hi Mehmet,

Mehmet Tekman <mtekman89@gmail.com> writes:

> ---
>  gnu/packages/xtrlock.scm | 71 ++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 71 insertions(+)
>  create mode 100644 gnu/packages/xtrlock.scm

I'd put this into (gnu packages xdisorg), next to xlockmore :-).

> diff --git a/gnu/packages/xtrlock.scm b/gnu/packages/xtrlock.scm
> new file mode 100644
> index 0000000000..2acf45e8b3
> --- /dev/null
> +++ b/gnu/packages/xtrlock.scm
> @@ -0,0 +1,71 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2022 Mehmet Tekman <mtekman89@gmail.com>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages xtrlock)
> +  #:use-module (guix packages)
> +  #:use-module (guix download)
> +  #:use-module (guix build-system gnu)
> +  #:use-module (gnu packages xorg)
> +  #:use-module ((guix licenses) #:prefix license:)
> +  )

^ lonely parens, and please sort lexicographically.

> +(define-public xtrlock
> +  (let ((pkg-version "2.15")
> +        (pkg-hash "0mgpysbvipd5h6x6zz4hng6b13gp3qjnpgny3azyj8k8dv85bppw")
> +        (recipe-revision "0"))
> +    (package
> +      (name "xtrlock")
> +      (version (string-append pkg-version ".r" recipe-revision))
> +      (source (origin
> +                (method url-fetch)
> +                (uri (string-append
> +                      "mirror://debian/pool/main/x/xtrlock/xtrlock_"
> +                      pkg-version ".tar.xz"))
> +                (sha256 (base32 pkg-hash))))
> +      (build-system gnu-build-system)
> +      (arguments
> +       '(#:make-flags
> +         (list "LDLIBS=-lX11 -lcrypt -lXi"
> +               "CFLAGS=-Wall -DSHADOW_PWD -DMULTITOUCH")

Does the build system not take care of the libraries link options
itself?

> +         #:phases
> +         (modify-phases
> +             %standard-phases

Nitpick: no need to put %standard-phases on a new line.

> +           (delete 'configure)
> +           (delete 'check)
> +           (add-after 'unpack 'rename-makefile
> +             (lambda _
> +               (rename-file "Makefile.noimake" "Makefile")
> +               (rename-file "xtrlock.man" "xtrlock.1")))
> +           (replace 'install
> +             (lambda* (#:key outputs #:allow-other-keys)
> +               (let* ((out (assoc-ref outputs "out")))
> +                 (install-file "xtrlock" (string-append out "/bin/"))
> +                 (install-file "xtrlock.1" (string-append out
> "/share/man/man1/"))))))))

Use 'guix style' to have it auto-formatted.

> +      (native-inputs (list libx11 libxi libxfixes))
> +      (home-page "https://packages.debian.org/sid/xtrlock")

There must be a better home page for the upstream of xtrlock than
Debian?  Edit: apparently Debian is the upstream.  Odd!

> +      (synopsis "Minimal X display lock program")
> +      (description "xtrlock locks the X server till the user enters
> their password at the
> +keyboard.  While xtrlock is running, the mouse and keyboard are grabbed and

Please reflow the paragraph; M-j in Emacs for example.

> +the mouse cursor becomes a padlock.  Output displayed by X programs, and
> +windows put up by new X clients, continue to be visible, and any new output is
> +displayed normally.  The mouse and keyboard are returned when the user types
> +their password, followed by Enter or Newline.  If an incorrect password is
> +entered the bell is sounded.  Pressing Backspace or Delete erases one
> +character of a password partially typed; pressing Escape or Clear clears
> +anything that has been entered.")
> +      (license license:gpl3))))

This is gpl3+ (GPL 3 or later).  See the license at
https://salsa.debian.org/debian/xtrlock/-/blob/master/GPL-3.txt, it
contains the "or any later version" text.

Could you please send a v2?  You could use something like: "git
send-email -v2 --to='58356@debbugs.gnu.org' -1" to send the tip of your
branch.
Mehmet Tekman Oct. 11, 2022, 10:45 a.m. UTC | #2
Hello, thanks again for the review!

The following has been changed:
* Placed into xdisorg.scm just after the xlockmore recipe
* Removed the CFLAGS, but kept the LDLIBS since it won't build without them
* General formatting (lint, style)
* License fix

I found it easier to spawn a new branch off master and create a new
patch than to append to the existing branch. I hope that's okay. The
patch is attached.

Best,
Mehmet
diff mbox series

Patch

diff --git a/gnu/packages/xtrlock.scm b/gnu/packages/xtrlock.scm
new file mode 100644
index 0000000000..2acf45e8b3
--- /dev/null
+++ b/gnu/packages/xtrlock.scm
@@ -0,0 +1,71 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Mehmet Tekman <mtekman89@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages xtrlock)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages xorg)
+  #:use-module ((guix licenses) #:prefix license:)
+  )
+
+(define-public xtrlock
+  (let ((pkg-version "2.15")
+        (pkg-hash "0mgpysbvipd5h6x6zz4hng6b13gp3qjnpgny3azyj8k8dv85bppw")
+        (recipe-revision "0"))
+    (package
+      (name "xtrlock")
+      (version (string-append pkg-version ".r" recipe-revision))
+      (source (origin
+                (method url-fetch)
+                (uri (string-append
+                      "mirror://debian/pool/main/x/xtrlock/xtrlock_"
+                      pkg-version ".tar.xz"))
+                (sha256 (base32 pkg-hash))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:make-flags
+         (list "LDLIBS=-lX11 -lcrypt -lXi"
+               "CFLAGS=-Wall -DSHADOW_PWD -DMULTITOUCH")
+         #:phases
+         (modify-phases
+             %standard-phases
+           (delete 'configure)
+           (delete 'check)
+           (add-after 'unpack 'rename-makefile
+             (lambda _
+               (rename-file "Makefile.noimake" "Makefile")
+               (rename-file "xtrlock.man" "xtrlock.1")))
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out")))
+                 (install-file "xtrlock" (string-append out "/bin/"))
+                 (install-file "xtrlock.1" (string-append out
"/share/man/man1/"))))))))
+      (native-inputs (list libx11 libxi libxfixes))
+      (home-page "https://packages.debian.org/sid/xtrlock")
+      (synopsis "Minimal X display lock program")
+      (description "xtrlock locks the X server till the user enters
their password at the
+keyboard.  While xtrlock is running, the mouse and keyboard are grabbed and
+the mouse cursor becomes a padlock.  Output displayed by X programs, and
+windows put up by new X clients, continue to be visible, and any new output is
+displayed normally.  The mouse and keyboard are returned when the user types
+their password, followed by Enter or Newline.  If an incorrect password is
+entered the bell is sounded.  Pressing Backspace or Delete erases one
+character of a password partially typed; pressing Escape or Clear clears