diff mbox series

[bug#64299] gnu: python-mypy: Update to 1.4.1.

Message ID CAH9Ak7L9bDL_NBvV+48fRn5+-5FDdP7UmpsdfoztRf3=ORsjzQ@mail.gmail.com
State New
Headers show
Series [bug#64299] gnu: python-mypy: Update to 1.4.1. | expand

Commit Message

Vincent Prat June 26, 2023, 9:53 a.m. UTC

Comments

Christopher Baines Sept. 15, 2023, 10:32 a.m. UTC | #1
Vincent Prat <vprat@deeplinks.com> writes:

> [2. text/x-patch; 0002-gnu-python-mypy-Fix-style.patch]...
>
> [3. text/x-patch; 0001-gnu-python-mypy-Update-to-1.4.1.patch]...

I missed the 2nd patch here, but I've pushed the first one as
eeeaf13984b96ca8856532559d5ab755c560e42c.

python-mypy does have quite a few dependencies, but QA had processed it
so it seemed OK to push.

Thanks,

Chris
diff mbox series

Patch

From c42d4cbc518d200e1e31a31ce2e27effa1e7abed Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Mon, 26 Jun 2023 11:44:47 +0200
Subject: [PATCH 1/2] gnu: python-mypy: Update to 1.4.1.

* gnu/packages/python-check.scm (python-mypy): Update to 1.4.1.
---
 gnu/packages/python-check.scm | 23 +++++------------------
 1 file changed, 5 insertions(+), 18 deletions(-)

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 87e15b4560..3a718954c5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1834,24 +1834,14 @@  (define-public python-mypy-extensions
 (define-public python-mypy
   (package
     (name "python-mypy")
-    (version "0.971")
+    (version "1.4.1")
     (source
      (origin
-       ;; Because of https://github.com/python/mypy/issues/9584, the
-       ;; mypyc/analysis directory is missing in the PyPI archive, leading to
-       ;; test failures.
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/python/mypy")
-             (commit (string-append "v" version))
-             ;; Fetch git submodules otherwise typeshed is not fetched.
-             ;; Typeshed is a collection of Python sources type annotation
-             ;; (data) files.
-             (recursive? #t)))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       (uri (pypi-uri "mypy" version))
        (sha256
         (base32
-         "0i8swdynms1wpiprgqn24za6mx8rlgxr2jash3cb5xi8jyf58n97"))))
+         "06svfmqbnb45pydy8lcrr12wqhhla5dl888w0g4f3wm1ismxkg4v"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1859,10 +1849,7 @@  (define-public python-mypy
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest" "-vv" "mypyc"
-                       ;; XXX: This test gets an unexpected DeprecationWarning
-                       ;; from recent versions of setuptools.  Ignore for now.
-                       "-k" "not testImports")))))))
+               (invoke "pytest" "mypyc")))))))
     (native-inputs
      (list python-attrs
            python-lxml
-- 
2.39.2