diff mbox series

[bug#55180] gnu: Add python-arpeggio.

Message ID CAH9Ak7J1VNBfGgDwG1dtiSgSxZeWaUbSmL++F_Xd_LYsMyDkzg@mail.gmail.com
State Accepted
Headers show
Series [bug#55180] gnu: Add python-arpeggio. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Prat April 29, 2022, 7:49 a.m. UTC

Comments

Paul A. Patience April 29, 2022, 8:28 a.m. UTC | #1
Hello,

Some typos in the description:

- pacrat -> packrat
- tool-chain -> toolchain
- all sort of -> all sorts of

Cheers,
Paul
Ludovic Courtès May 6, 2022, 8:29 a.m. UTC | #2
Hi,

Vincent Prat <vprat@deeplinks.com> skribis:

> From 6dbafb4d9036cf76096b7860be6b2c91882efa3f Mon Sep 17 00:00:00 2001
> From: Vincent Prat <vprat@deeplinks.com>
> Date: Fri, 29 Apr 2022 09:43:35 +0200
> Subject: [PATCH] gnu: Add python-arpeggio.
>
> * gnu/packages/python-xyz.scm (python-arpeggio): New variable.

Applied together with the followup fixes, thanks!

Ludo’.
diff mbox series

Patch

From 6dbafb4d9036cf76096b7860be6b2c91882efa3f Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Fri, 29 Apr 2022 09:43:35 +0200
Subject: [PATCH] gnu: Add python-arpeggio.

* gnu/packages/python-xyz.scm (python-arpeggio): New variable.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f8e599a453..af9244c3ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29587,3 +29587,32 @@  and setting the color of terminal output, via HyDEV.")
 versions of MkDocs-powered docs to a Git branch.  It is suitable for deploying
 to Github via gh-pages.")
     (license license:bsd-3)))
+
+(define-public python-arpeggio
+  (package
+    (name "python-arpeggio")
+    (version "2.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "Arpeggio" version))
+              (sha256
+               (base32
+                "0ggdsck1wpladd5bh9drhkmm86bblgk2wagrhn3sdf4v04wkic6n"))))
+    (build-system python-build-system)
+    (native-inputs (list python-coverage
+                         python-coveralls
+                         python-flake8
+                         python-mike
+                         python-mkdocs
+                         python-pytest
+                         python-pytest-runner
+                         python-twine
+                         python-wheel))
+    (home-page "https://github.com/textX/Arpeggio")
+    (synopsis "Packrat parser interpreter for Python")
+    (description
+     "This Python library provides a recursive descent parser with backtracking
+and memoization (a.k.a. pacrat parser).  Arpeggio grammars are based on PEG
+formalism.  Arpeggio's main use is a foundation for a tool-chain for DSL
+development but it can be used for all sort of general purpose parsing.")
+    (license license:expat)))
-- 
2.30.2