diff mbox series

[bug#57657] python-ipython currently does not build

Message ID CAGdf7-GgOw0V8RfhKq-kKF6-Pe7N9Csau34DznrcOKD-FqRO-A@mail.gmail.com
State Accepted
Headers show
Series [bug#57657] python-ipython currently does not build | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ben Van Sleen Sept. 7, 2022, 10:02 p.m. UTC
Hi,

Hope y'all are well!

python-ipython does not build due to failing tests in python-pydevd. The
older version on python-pydevd simply disables these tests. I'm submitting
a patch to disable the tests on the current version as well.

Best,
Ben Van Sleen


From c3d2255a401bda1a16df6052133163262dc57ab3 Mon Sep 17 00:00:00 2001
From: Ben Van Sleen <benvansleen@gmail.com>
Date: Wed, 7 Sep 2022 16:06:00 -0500
Subject: [PATCH] python-pydevd v2.8.0: Disable failing tests due to
deprecated
 decorator

---
 gnu/packages/python-xyz.scm | 1 +
 1 file changed, 1 insertion(+)

--
2.37.3

Comments

Christopher Baines Sept. 11, 2022, 8:08 p.m. UTC | #1
Ben Van Sleen <benvansleen@gmail.com> writes:

> Hi,
>
> Hope y'all are well!
>
> python-ipython does not build due to failing tests in python-pydevd. The older version on python-pydevd simply disables these tests. I'm
> submitting a patch to disable the tests on the current version as well.

Hi Ben,

Can you clarify what failure you see, and maybe what revision of Guix
you're using?

Both python-pydevd and python-ipython seem to build for me currently.

Thanks,

Chris
Christopher Baines Sept. 19, 2022, 7:44 a.m. UTC | #2
Ben Van Sleen <benvansleen@gmail.com> writes:

> Just did a fresh guix pull, and everything is building fine again. Not
> sure what my issue was last week.
>
> Thanks for the help!

Thanks for confirming Ben, I'll close the issue.

Chris
diff mbox series

Patch

From c3d2255a401bda1a16df6052133163262dc57ab3 Mon Sep 17 00:00:00 2001
From: Ben Van Sleen <benvansleen@gmail.com>
Date: Wed, 7 Sep 2022 16:06:00 -0500
Subject: [PATCH] python-pydevd v2.8.0: Disable failing tests due to deprecated
 decorator

---
 gnu/packages/python-xyz.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b058704172..9047f848ef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12741,6 +12741,7 @@  (define-public python-pydevd
       (build-system python-build-system)
       (arguments
        (list
+        #:tests? #f
         #:phases
         #~(modify-phases %standard-phases
             (add-after 'unpack 'fix-tests
-- 
2.37.3