diff mbox series

[bug#54477] gnu: Add sbase.

Message ID CAGNyvejNNZNMW8gwRvyGuwU6p-P7HYNF1rHcV=ghPiG4va+YMQ@mail.gmail.com
State Accepted
Headers show
Series [bug#54477] gnu: Add sbase. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

路辉 March 20, 2022, 2:49 p.m. UTC

Comments

M March 20, 2022, 3:19 p.m. UTC | #1
路辉 schreef op zo 20-03-2022 om 14:49 [+0000]:
> From 9f3ff0979c033b85a3d82baf79f294cac7cf3a4d Mon Sep 17 00:00:00
> 2001
> From: Lu Hui <luhux76@gmail.com>
> Date: Sun, 20 Mar 2022 22:45:53 +0800
> Subject: [PATCH] gnu: Add sbase.
> 
> * gnu/packages/suckless.scm (sbase): New Variables.

This is a duplicate of <https://issues.guix.gnu.org/53825>, so closing.
diff mbox series

Patch

From 9f3ff0979c033b85a3d82baf79f294cac7cf3a4d Mon Sep 17 00:00:00 2001
From: Lu Hui <luhux76@gmail.com>
Date: Sun, 20 Mar 2022 22:45:53 +0800
Subject: [PATCH] gnu: Add sbase.

* gnu/packages/suckless.scm (sbase): New Variables.
---
 gnu/packages/suckless.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 5aa37657b9..c367cc8f91 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
 ;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Lu Hui <luhux76@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1084,3 +1085,41 @@  (define-public sfeed
 various other formats.  There are also some programs and scripts included to
 import and export OPML and to fetch, filter, merge and order feed items.")
     (license license:isc)))
+
+(define-public sbase
+  (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd") (revision "0"))
+    (package
+      (name "sbase")
+      (version (git-version "20190904" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.suckless.org/sbase/")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:tests?
+             #f ;no check target
+             #:make-flags
+             #~(list (string-append "CC="
+                                    #$(cc-for-target))
+                     (string-append "PREFIX="
+                                    #$output))
+             #:phases
+             '(modify-phases %standard-phases
+                (replace 'install
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let ((out (assoc-ref outputs "out")))
+                      (invoke "make" "install"
+                              (string-append "DESTDIR=" out) "PREFIX="))))
+                (delete 'configure)))) ;no configure script
+      (home-page "https://git.suckless.org/sbase/file/README.html")
+      (synopsis "Suckless unix tools set")
+      (description
+       "sbase is a collection of unix tools that are inherently portable
+across UNIX and UNIX-like systems.")
+      (license license:x11))))
-- 
2.34.0