diff mbox series

[bug#57865] gnu: bdb: fix the cross build.

Message ID CAGNyveizUVhkJR3at6JTVouB=4LbfkfK_2v0HsHYdyCNdy7cYA@mail.gmail.com
State Accepted
Headers show
Series [bug#57865] gnu: bdb: fix the cross build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

路辉 Sept. 16, 2022, 3:04 p.m. UTC

Comments

Christopher Baines Oct. 8, 2022, 11:09 a.m. UTC | #1
路辉 <luhux76@gmail.com> writes:

> [2. text/x-patch; 0001-gnu-bdb-fix-the-cross-build.patch]...

Thanks, I've tweaked the commit message a bit to make it more specific
and pushed this to master as 14afaa5381b1185bf9e3701ff09c5bab12dacfab.

Chris
diff mbox series

Patch

From d9bc4d42ca2d5a06def537d143c85c289bdb9c39 Mon Sep 17 00:00:00 2001
From: Lu Hui <luhux76@gmail.com>
Date: Fri, 16 Sep 2022 23:02:28 +0800
Subject: [PATCH] gnu: bdb: fix the cross build.

* gnu/packages/dbm.scm (bdb): fix cross build
---
 gnu/packages/dbm.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/dbm.scm b/gnu/packages/dbm.scm
index 8b6804aa92..2d3cce9e15 100644
--- a/gnu/packages/dbm.scm
+++ b/gnu/packages/dbm.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 LuHui <luhux76@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -65,7 +66,8 @@  (define-public bdb-4.8
          ;; for "--build", but not for "--host", so update config.sub.
          ,@(if (and (%current-target-system)
                     (or (target-ppc64le? (%current-target-system))
-                        (target-aarch64? (%current-target-system))))
+                        (target-aarch64? (%current-target-system))
+                        (target-riscv64? (%current-target-system))))
                `((add-after 'unpack 'update-config.sub
                    (lambda* (#:key native-inputs #:allow-other-keys)
                      (delete-file "dist/config.sub")
@@ -118,7 +120,8 @@  (define-public bdb-4.8
     (native-inputs
      (if (and (%current-target-system)
               (or (target-ppc64le? (%current-target-system))
-                  (target-aarch64? (%current-target-system))))
+                  (target-aarch64? (%current-target-system))
+                  (target-riscv64? (%current-target-system))))
          `(("config" ,config)) ; for config.sub
          '()))
     (synopsis "Berkeley database")
-- 
2.37.3