[bug#58754] gnu: Add new variable gkermit

Message ID CAGNyvehWU2dq8Ke6PS90_edwoaYS1AaJG53V-f7ZzME0ViUEJQ@mail.gmail.com
State New
Headers
Series [bug#58754] gnu: Add new variable gkermit |

Commit Message

路辉 Oct. 24, 2022, 5:17 a.m. UTC
  add new tool for embedded developing
  

Comments

Christopher Baines Nov. 5, 2022, 10:32 a.m. UTC | #1
路辉 <luhux76@gmail.com> writes:

> add new tool for embedded developing

Thanks for the patch. I've noted two hopefully minor issues below. Would
you be able to take a look at sending an updated patch?

> +(define-public gkermit
> +  (package
> +    (name "gkermit")
> +    (version "2.01")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/KermitProject/gkermit")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0njxzwnvanrdnx6cs7y0136g2179wx8wbqk8iqxpb48dr2hg7zn1"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f

From looking at the source, I guess the reason for this is that there
are no included tests to run. If that is correct, it would be good to
note the reason in a comment.

> +       #:make-flags (list (string-append "CC="
> +                                         ,(cc-for-target))
> +                          (string-append "PREFIX="
> +                                         (assoc-ref %outputs "out")))
> +       #:phases (modify-phases %standard-phases
> +                  (delete 'configure)
> +                  (add-before 'build 'replace-hardcodepath
> +                    (lambda* (#:key outputs #:allow-other-keys)
> +                      (let* ((out (assoc-ref outputs "out"))
> +                             (bin (string-append out "/bin"))
> +                             (doc (string-append out "/share/doc"))
> +                             (man1 (string-append out "/share/man/man1"))
> +                             (info (string-append out "/share/info")))
> +                        (substitute* "makefile"
> +                          (("/usr/local/bin")
> +                           bin)
> +                          (("/usr/man/manl")
> +                           man1) ;may be a typo err?
> +                          (("/usr/local/doc")
> +                           doc)
> +                          (("/usr/local/info")
> +                           info)
> +                          (("CC=cc")
> +                           "CC ?= cc"))
> +                        (mkdir-p bin)
> +                        (mkdir-p doc)
> +                        (mkdir-p man1)
> +                        (mkdir-p info)))))))
> +
> +    (home-page "https://github.com/KermitProject/gkermit")
> +    (synopsis "Kermit for UNIX")
> +    (description
> +     "Use for uploading and downloading files with Kermit protocol")
> +    (license license:gpl2)))

Can you check this, at least some files I looked at weren't strict gpl2
only.

Thanks,

Chris
  

Patch

From b0a14ae79dfb7baafcae88ff85f50578607fb7d1 Mon Sep 17 00:00:00 2001
From: LuHui <luhux76@gmail.com>
Date: Mon, 24 Oct 2022 13:13:58 +0800
Subject: [PATCH] gnu: Add new variable gkermit

* gnu/packages/admin.scm (gkermit): Add new variable.
---
 gnu/packages/admin.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4539e92a8c..f6aaf007f9 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -55,6 +55,7 @@ 
 ;;; Copyright © 2022 Andreas Rammhold <andreas@rammhold.de>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2022 LuHui <luhux76@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5646,3 +5647,54 @@  (define (install-completion shell file)
     (description
      "@code{doctl} provides a unified command line interface to the DigitalOcean API.")
     (license license:asl2.0)))
+
+(define-public gkermit
+  (package
+    (name "gkermit")
+    (version "2.01")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/KermitProject/gkermit")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0njxzwnvanrdnx6cs7y0136g2179wx8wbqk8iqxpb48dr2hg7zn1"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:make-flags (list (string-append "CC="
+                                         ,(cc-for-target))
+                          (string-append "PREFIX="
+                                         (assoc-ref %outputs "out")))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (add-before 'build 'replace-hardcodepath
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let* ((out (assoc-ref outputs "out"))
+                             (bin (string-append out "/bin"))
+                             (doc (string-append out "/share/doc"))
+                             (man1 (string-append out "/share/man/man1"))
+                             (info (string-append out "/share/info")))
+                        (substitute* "makefile"
+                          (("/usr/local/bin")
+                           bin)
+                          (("/usr/man/manl")
+                           man1) ;may be a typo err?
+                          (("/usr/local/doc")
+                           doc)
+                          (("/usr/local/info")
+                           info)
+                          (("CC=cc")
+                           "CC ?= cc"))
+                        (mkdir-p bin)
+                        (mkdir-p doc)
+                        (mkdir-p man1)
+                        (mkdir-p info)))))))
+
+    (home-page "https://github.com/KermitProject/gkermit")
+    (synopsis "Kermit for UNIX")
+    (description
+     "Use for uploading and downloading files with Kermit protocol")
+    (license license:gpl2)))
-- 
2.38.0