diff mbox series

[bug#71141] (gnu packages guile-xyz): + srfi-126

Message ID CAGJuR-7q3xSKNriZqUXZbjRYQJ84OfgWdBBVi26vn--5LmFo2g@mail.gmail.com
State New
Headers show
Series [bug#71141] (gnu packages guile-xyz): + srfi-126 | expand

Commit Message

Grigory Shepelev May 23, 2024, 9:04 a.m. UTC

Comments

Grigory Shepelev May 24, 2024, 3:58 p.m. UTC | #1
Caught a mistake. Not sure about the license. Not GPL probably. From
https://srfi.schemers.org/srfi-126/srfi-126.html:

«Copyright (C) Taylan Ulrich Bayırlı/Kammer (2015, 2016). All Rights
Reserved.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the "Software"),
to deal in the Software without restriction, including without limitation
the rights to use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.»


чт, 23 мая 2024 г. в 12:04, Grigory Shepelev <shegeley@gmail.com>:

>
>
Leo Famulari May 24, 2024, 5:38 p.m. UTC | #2
That's the MIT / "Expat" license.

https://directory.fsf.org/wiki/License:Expat

On Fri, May 24, 2024, at 11:58, Grigory Shepelev wrote:
> Caught a mistake. Not sure about the license. Not GPL probably. From  https://srfi.schemers.org/srfi-126/srfi-126.html:
> «Copyright (C) Taylan Ulrich Bayırlı/Kammer (2015, 2016). All Rights Reserved.
> 
> Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
> 
> The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
> 
> THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.»
> 
> 
> 
> чт, 23 мая 2024 г. в 12:04, Grigory Shepelev <shegeley@gmail.com>:
>>
Grigory Shepelev May 24, 2024, 5:47 p.m. UTC | #3
Fixed the license. It's "expat".

пт, 24 мая 2024 г. в 18:58, Grigory Shepelev <shegeley@gmail.com>:

> Caught a mistake. Not sure about the license. Not GPL probably. From
> https://srfi.schemers.org/srfi-126/srfi-126.html:
>
> «Copyright (C) Taylan Ulrich Bayırlı/Kammer (2015, 2016). All Rights
> Reserved.
>
> Permission is hereby granted, free of charge, to any person obtaining a
> copy of this software and associated documentation files (the "Software"),
> to deal in the Software without restriction, including without limitation
> the rights to use, copy, modify, merge, publish, distribute, sublicense,
> and/or sell copies of the Software, and to permit persons to whom the
> Software is furnished to do so, subject to the following conditions:
>
> The above copyright notice and this permission notice shall be included in
> all copies or substantial portions of the Software.
>
> THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
> IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
> FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
> AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
> LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
> FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
> DEALINGS IN THE SOFTWARE.»
>
>
> чт, 23 мая 2024 г. в 12:04, Grigory Shepelev <shegeley@gmail.com>:
>
>>
>>
diff mbox series

Patch

From 3e08f2df8839f995d70203a58f093fc42f4141f4 Mon Sep 17 00:00:00 2001
From: Grigory Shepelev <shegeley@gmail.com>
Date: Thu, 23 May 2024 06:25:53 +0300
Subject: [PATCH] (gnu packages guile-xyz): + guile-srfi-126

---
 gnu/packages/guile-xyz.scm | 44 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index ffb0684167..0fc84bb2c1 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3791,6 +3791,50 @@  (define-public guile-srfi-133
 comprehensive library of vector operations.")
     (license license:expat)))
 
+(define-public guile-srfi-126
+ (let ((commit "f480cf2d1a33c1f3d0fab3baf321c0ed5b5eb248")
+       (revision "0"))
+  (package
+   (name "guile-srfi-126")
+   (version revision)
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://github.com/scheme-requests-for-implementation/srfi-126")
+           (commit commit)))
+     (file-name (git-file-name name version))
+     (modules '((guix build utils)))
+     (snippet
+      '(begin
+        (delete-file-recursively "r6rs")
+
+        (delete-file "srfi/126.sld")
+        (delete-file "srfi/126.sld.in")
+        (delete-file "srfi/:126.sls")
+        (delete-file "srfi/:126.sls.in")
+
+        (delete-file "test-suite.body.scm")
+        (delete-file "test-suite.r6rs.sps")
+        (delete-file "test-suite.r6rs.sps.in")
+        (delete-file "test-suite.r7rs.scm")
+        (delete-file "test-suite.r7rs.scm.in")
+        #t))
+     (sha256
+      (base32 "18psw8l798xmbv2h90cz41r51q1mydzg7yr71krfprx5kdfqn32q"))))
+   (build-system guile-build-system)
+   (native-inputs (list guile-3.0))
+   (home-page "https://github.com/scheme-requests-for-implementation/srfi-126")
+   (synopsis "SRFI 126: R6RS-based hashtables")
+   (description "The utility procedures provided by this SRFI in addition to the R6RS API may be categorized as follows:
+    - Constructors: alist->eq-hashtable, alist->eqv-hashtable, alist->hashtable
+    - Access and mutation: hashtable-lookup, hashtable-intern!
+    - Copying: hashtable-empty-copy
+    - Key/value collections: hashtable-values, hashtable-key-list, hashtable-value-list, hashtable-entry-lists
+    - Iteration: hashtable-walk, hashtable-update-all!, hashtable-prune!, hashtable-merge!, hashtable-sum, hashtable-map->lset, hashtable-find
+    - Miscellaneous: hashtable-empty?, hashtable-pop!, hashtable-inc!, hashtable-dec!")
+   (license license:gpl3+))))
+
 (define-public guile-srfi-145
   (package
     (name "guile-srfi-145")
-- 
2.41.0