diff mbox series

[bug#66422] «Joe R Marshall's Syntax-Rules Primer for the Merely Eccentric» package

Message ID CAGJuR-4V2ZGd_vYinU6O6Air9_qvsLbU_yF-iW_orksa=oSK1w@mail.gmail.com
State New
Headers show
Series [bug#66422] «Joe R Marshall's Syntax-Rules Primer for the Merely Eccentric» package | expand

Commit Message

Grigory Shepelev Oct. 9, 2023, 2:25 p.m. UTC
Hi
Texinfo-ed «Joe R Marshall's Syntax-Rules Primer for the Merely Eccentric»
and packed it into guix right after `sicp` package

Comments

Liliana Marie Prikler Oct. 12, 2023, 11:58 a.m. UTC | #1
Am Montag, dem 09.10.2023 um 17:25 +0300 schrieb Grigory Shepelev:
> Hi
> Texinfo-ed «Joe R Marshall's Syntax-Rules Primer for the Merely
> Eccentric» and packed it into guix right after `sicp` package
Sadly, neither this nor the original guide carry any copyright
information.  As such, they fall under whatever copyright applies by
default, which most likely means it won't belong to the public until 70
years after Joe's death.

Sorry

PS: Comparing your mail address and the source of the package, it would
appears as though you were the one to write this up as a texinfo
document.  You may wish to consult Joe as to whether you are allowed to
redistribute copies of their work.  Note that this does not fall under
any exceptions such as academic citing, etc.
diff mbox series

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index ad06d7db06..cdb56efb95 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -658,6 +658,38 @@  (define-public sicp
 metalinguistic abstraction, recursion, interpreters, and modular programming.")
       (license cc-by-sa4.0))))
 
+(define-public jrm-syntax-rules
+  (let [(commit "6968df3ebc6de4cf8d41aa7b6adc400a11937b86")
+        (hash "1l8221q1zw66yb47dcqbbnj3dbsl6slvnivaqc731hs848apwffr")
+        (revision "1")]
+    (package
+      (name "jrm-syntax-rules")
+      (version "1.0.0")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/shegeley/jrm-syntax-rules")
+                      (commit commit)))
+                (sha256 (base32 hash))
+                (file-name (git-file-name name version))))
+      (build-system copy-build-system)
+      (native-inputs (list gzip texinfo))
+      (arguments
+       (list #:install-plan ''(("jrm-syntax-rules.info" "share/info/"))
+             #:phases #~(modify-phases
+                            %standard-phases
+                          (add-before
+                              'install 'build
+                            (lambda _
+                              (invoke "makeinfo"
+                                      "--output=jrm-syntax-rules.info"
+                                      "doc.texi"))))))
+      (home-page "https://github.com/shegeley/jrm-syntax-rules")
+      (synopsis "JRM’s Syntax-rules Primer for the Merely Eccentric")
+      (description "Tutorial for syntax-rules system in R5RS standard.")
+      ;; NOTE: coudn't find any info on licensing. seems like public domain. fix me if I'm wrong
+      (license public-domain))))
+
 (define-public scheme48-rx
   (let* ((commit "dd9037f6f9ea01019390614f6b126b7dd293798d")
          (revision "2"))