diff mbox series

[bug#64473] doc: Update GDB "guix shell" example to use autoconf-2.69

Message ID CAFyhPjXFmt27gxBn0mzUn+SY5++xDgrW7ERY66msAps0TNQ-Eg@mail.gmail.com
State New
Headers show
Series [bug#64473] doc: Update GDB "guix shell" example to use autoconf-2.69 | expand

Commit Message

Michael Ford July 5, 2023, 10:58 a.m. UTC
GDB has switched to using autoconf 2.69 for development
(d0ac1c44885daf68f631befa37e3f3bad318fbbf).
Running the GDB shell example, and then using autoreconf currently fails with:

guix shell -D -f ../guix/doc/environment-gdb.scm --pure
autoreconf
configure.ac:35: error: Please use exactly Autoconf 2.69 instead of 2.64.
config/override.m4:12: _GCC_AUTOCONF_VERSION_CHECK is expanded from...
configure.ac:35: the top level
autom4te: /gnu/store/2awzcd1jdd8h65ahdn62ydllrs2s2pk1-m4-1.4.19/bin/m4
failed with exit status: 1
aclocal: error: autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1

Update the example environment to use 2.69. At the same time, remove
the outdated comment from the autoconf-2.64 package. At this point,
the package could possibly also be removed, but I'm not sure about the
procedure around removing packages, so left it as-is.

From 2af09ead05834a8f8c56fa30b4b2d00461b132c2 Mon Sep 17 00:00:00 2001
From: fanquake <fanquake@gmail.com>
Date: Wed, 5 Jul 2023 11:52:24 +0100
Subject: [PATCH] doc: Update GDB "guix shell" example to use autoconf-2.69

* doc/environment-gdb.scm: Change to use autoconf-2.69.
* gnu/packages/autotools.scm: Remove outdated GDB comment.
---
 doc/environment-gdb.scm    | 2 +-
 gnu/packages/autotools.scm | 1 -
 2 files changed, 1 insertion(+), 2 deletions(-)

Comments

Ludovic Courtès July 17, 2023, 10:19 p.m. UTC | #1
Hi,

Michael Ford <fanquake@gmail.com> skribis:

>>From 2af09ead05834a8f8c56fa30b4b2d00461b132c2 Mon Sep 17 00:00:00 2001
> From: fanquake <fanquake@gmail.com>
> Date: Wed, 5 Jul 2023 11:52:24 +0100
> Subject: [PATCH] doc: Update GDB "guix shell" example to use autoconf-2.69
>
> * doc/environment-gdb.scm: Change to use autoconf-2.69.
> * gnu/packages/autotools.scm: Remove outdated GDB comment.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/doc/environment-gdb.scm b/doc/environment-gdb.scm
index 0534e594de..9517200ffd 100644
--- a/doc/environment-gdb.scm
+++ b/doc/environment-gdb.scm
@@ -9,4 +9,4 @@ 
 (package
   (inherit gdb)
   (native-inputs (modify-inputs (package-native-inputs gdb)
-                   (prepend autoconf-2.64 automake texinfo))))
+                   (prepend autoconf-2.69 automake texinfo))))
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index fc6bb196f1..5ffefec4a1 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -158,7 +158,6 @@  (define-public autoconf-2.68
         "1fjm21k2na07f3vasf288a0zx66lbv0hd3l9bvv3q8p62s3pg569"))))))

 (define-public autoconf-2.64
-  ;; As of GDB 7.8, GDB is still developed using this version of Autoconf.
   (package (inherit autoconf)
     (version "2.64")
     (source