diff mbox series

[bug#66968] gnu: linux-libre: add linux-libre-stable & linux-libre-longterm

Message ID CAFyhPjW_ouvj8+_Fph4Rp838dqW8Re8dBx-5yjit5DxD0b=AXA@mail.gmail.com
State New
Headers show
Series [bug#66968] gnu: linux-libre: add linux-libre-stable & linux-libre-longterm | expand

Commit Message

Michael Ford Nov. 6, 2023, 1:26 p.m. UTC
From dbe93718ea3dbae9d3e4795d0cea239cd3d6a674 Mon Sep 17 00:00:00 2001
From: fanquake <fanquake@gmail.com>
Date: Sun, 5 Nov 2023 18:31:55 +0000
Subject: [PATCH] gnu: linux-libre: add linux-libre-stable &
 linux-libre-longterm

A project I'm involved with would find it convenient to have pointers to
the current stable / longterm kernel header branches, without having to
specify an exact version. This way, we can point to i.e the longterm
branch, and with each time-machine "bump", continue to have whatever the
current longerm branch happens to be. So I'm submitting this patch for
discussion / inclusion. Obviouly one overhead is remembering to keep
these variables in sync whenever the status of the longterm/stable
branches changes.

* gnu/packages/linux (linux-libre-stable): New variable.
  (linux-libre-longerm): New variable.
---
 gnu/packages/linux.scm | 2 ++
 1 file changed, 2 insertions(+)


 ;;;
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 95a66e3d6a..a50526734e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -790,6 +790,8 @@  (define-public linux-libre-headers-5.15.49

"13zqdcm4664vh7g57sxbfrlpsxm7zrma72mxdfdz7d9yndy2gfv8"))

 (define-public linux-libre-headers linux-libre-headers-5.15.49)
+(define-public linux-libre-stable linux-libre-headers-6.5)
+(define-public linux-libre-longterm linux-libre-headers-6.1)