diff mbox series

[bug#59573] gnu: Update bitcoin-core to 24.0

Message ID CAFyhPjUEENcJ0+K=wTW6tbriFKTZM+VmY2Rc-XYg7nTyiHA7pA@mail.gmail.com
State New
Headers show
Series [bug#59573] gnu: Update bitcoin-core to 24.0 | expand

Commit Message

Michael Ford Nov. 25, 2022, 3:26 p.m. UTC
Resending this inline, as the attached .patch is not usable.

Retain 23.0 as it's still supported.
Update homepage to bitcoincore.org.
---
 gnu/packages/finance.scm | 24 +++++++++++++++++++-----
 1 file changed, 19 insertions(+), 5 deletions(-)

      "Bitcoin is a digital currency that enables instant payments to anyone
@@ -207,10 +208,23 @@ (define-public bitcoin-core-23.0
 line client and a client based on Qt.")
     (license license:expat)))

+(define-public bitcoin-core-23.0
+  (package
+    (inherit bitcoin-core-24)
+    (version "23.0")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "https://bitcoincore.org/bin/bitcoin-core-"
+                              version "/bitcoin-" version ".tar.gz"))
+              (sha256
+               (base32
+
 "01fcb90pqip3v77kljykx51cmg7jdg2cmp7ys0a40svdkps8nx16"))))))
+
 ;; The support lifetimes for bitcoin-core versions can be found in
 ;; <https://bitcoincore.org/en/lifecycle/#schedule>.

-(define-public bitcoin-core bitcoin-core-23.0)
+(define-public bitcoin-core bitcoin-core-24.0)

 (define-public hledger
   (package

Comments

Vagrant Cascadian Sept. 2, 2023, 4:33 a.m. UTC | #1
On 2022-11-25, Michael Ford wrote:
> -(define-public bitcoin-core-23.0
> +(define-public bitcoin-core-24.0
>    (package
>      (name "bitcoin-core")
> -    (version "23.0")
> +    (version "24.0")

bitcoin-core has since been updated to newer versions:

0aab24855238cc7c7a31066ab39cd94e534b857f gnu: bitcoin-core: Update to 24.1.
b58fab5982eb45aae2a51c86093e6bbd472d8c9e gnu: bitcoin-core: Update to 25.0.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index feb533eca7..29589c09b8 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2022 Collin J. Doering <collin@rekahsoft.ca>
 ;;; Copyright © 2022 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2022 Michael Ford <fanquake@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -129,10 +130,10 @@  (define-module (gnu packages finance)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages gnuzilla))

-(define-public bitcoin-core-23.0
+(define-public bitcoin-core-24.0
   (package
     (name "bitcoin-core")
-    (version "23.0")
+    (version "24.0")
     (source (origin
               (method url-fetch)
               (uri
@@ -140,7 +141,7 @@  (define-public bitcoin-core-23.0
                               version "/bitcoin-" version ".tar.gz"))
               (sha256
                (base32
-                "01fcb90pqip3v77kljykx51cmg7jdg2cmp7ys0a40svdkps8nx16"))))
+                "1x6riward8z8rx6wvypsz3rnfl7hy2986llbbgl96l6b9aglmylw"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf
@@ -196,7 +197,7 @@  (define-public bitcoin-core-23.0
               "python3" "./test/functional/test_runner.py"
               (string-append "--jobs=" (number->string
(parallel-job-count))))
              #t)))))
-    (home-page "https://bitcoin.org/")
+    (home-page "https://bitcoincore.org/")
     (synopsis "Bitcoin peer-to-peer client")
     (description