diff mbox series

[bug#41345] 000-update-python-argon2-cffi.patch

Message ID CAFkJGRevx7HfdA5=gCSgtumgPt1zjLqVvK+-Gfy1J4_GDOm81g@mail.gmail.com
State Accepted
Headers show
Series [bug#41345] 000-update-python-argon2-cffi.patch | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Anadon May 17, 2020, 4:20 a.m. UTC
(build-system python-build-system)

Comments

Marius Bakke May 20, 2020, 9:01 p.m. UTC | #1
Hi Josh,

Can you resubmit this patch with a proper commit message?

Thanks!
Anadon May 20, 2020, 9:07 p.m. UTC | #2
Sure.  This was before I figured out `git send-email`.

On Wed, May 20, 2020, 17:01 Marius Bakke <mbakke@fastmail.com> wrote:

> Hi Josh,
>
> Can you resubmit this patch with a proper commit message?
>
> Thanks!
>
Anadon May 25, 2020, 11:55 a.m. UTC | #3
Resubmitted the patch more properly made.  Looks like it didn't continue
this thread.  How do I close this?

On Wed, May 20, 2020, 17:07 Josh Marshall <joshua.r.marshall.1991@gmail.com>
wrote:

> Sure.  This was before I figured out `git send-email`.
>
> On Wed, May 20, 2020, 17:01 Marius Bakke <mbakke@fastmail.com> wrote:
>
>> Hi Josh,
>>
>> Can you resubmit this patch with a proper commit message?
>>
>> Thanks!
>>
>
Marius Bakke May 25, 2020, 2:59 p.m. UTC | #4
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

> Resubmitted the patch more properly made.  Looks like it didn't continue
> this thread.  How do I close this?

It still did not have a commit message though:

https://git.savannah.gnu.org/cgit/guix.git/log/gnu/packages?id=9813805b30dad444984111d5413b8ab7356f7908

Note how it differs from other package updates, in particular lacking
the '* gnu/packages/file.scm (variable):' line, as well as the "gnu: "
prefix.  No big deal, but try to follow the convention next time.

In any case you can close bugs by appending -done to the issue ID, like
I've done in this message.  Thanks!
Anadon May 25, 2020, 4:13 p.m. UTC | #5
Here is what I'm doing:
```
git commit -am "Updating python-argon2-cffi to 20.1.0"
git format-patch master
git send-email --to=guix-patches@gnu.org
--subject="000-update-python-argon2-cffi.patch"
0001-Updating-python-argon2-cffi-to-20.1.0.patch
```

When reading https://guix.gnu.org/manual/en/guix.html#Submitting-Patches
I do not see guidance on this particular aspect of sending patches.
What do I need to alter, and should those details be added to the
manual?

On Mon, May 25, 2020 at 10:59 AM Marius Bakke <marius@gnu.org> wrote:
>
> Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:
>
> > Resubmitted the patch more properly made.  Looks like it didn't continue
> > this thread.  How do I close this?
>
> It still did not have a commit message though:
>
> https://git.savannah.gnu.org/cgit/guix.git/log/gnu/packages?id=9813805b30dad444984111d5413b8ab7356f7908
>
> Note how it differs from other package updates, in particular lacking
> the '* gnu/packages/file.scm (variable):' line, as well as the "gnu: "
> prefix.  No big deal, but try to follow the convention next time.
>
> In any case you can close bugs by appending -done to the issue ID, like
> I've done in this message.  Thanks!
Marius Bakke May 25, 2020, 9:35 p.m. UTC | #6
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

> When reading https://guix.gnu.org/manual/en/guix.html#Submitting-Patches
> I do not see guidance on this particular aspect of sending patches.
> What do I need to alter, and should those details be added to the
> manual?

It's not very prominent, but it's there:

  Please write commit logs in the ChangeLog format (see Change Logs in
  GNU Coding Standards); you can check the commit history for examples.

With a link to the GNU Coding Standards document:

  https://www.gnu.org/prep/standards/standards.html#Change-Logs

Perhaps we could include a condensed version as it borders on TL;DR.

>  git commit -am "Updating python-argon2-cffi to 20.1.0"

If you omit the -m, git will open your $EDITOR where you can contemplate
on how best to communicate what the patch does, and write over multiple
lines.  There are helper functions in Emacs to fill out the boring
"* gnu/packages/file-name.scm (variable):" part of the commit message.

When unsure, I recommend running "git log the-file.scm" and look at
previous commit messages for inspiration.

Thanks for persevering!  :-)
Anadon May 25, 2020, 10:39 p.m. UTC | #7
If those are the particular expectations and standards, should they change
from only policy in the manual to something enforced by a git pre-commit
hook?

On Mon, May 25, 2020, 17:35 Marius Bakke <marius@gnu.org> wrote:

> Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:
>
> > When reading https://guix.gnu.org/manual/en/guix.html#Submitting-Patches
> > I do not see guidance on this particular aspect of sending patches.
> > What do I need to alter, and should those details be added to the
> > manual?
>
> It's not very prominent, but it's there:
>
>   Please write commit logs in the ChangeLog format (see Change Logs in
>   GNU Coding Standards); you can check the commit history for examples.
>
> With a link to the GNU Coding Standards document:
>
>   https://www.gnu.org/prep/standards/standards.html#Change-Logs
>
> Perhaps we could include a condensed version as it borders on TL;DR.
>
> >  git commit -am "Updating python-argon2-cffi to 20.1.0"
>
> If you omit the -m, git will open your $EDITOR where you can contemplate
> on how best to communicate what the patch does, and write over multiple
> lines.  There are helper functions in Emacs to fill out the boring
> "* gnu/packages/file-name.scm (variable):" part of the commit message.
>
> When unsure, I recommend running "git log the-file.scm" and look at
> previous commit messages for inspiration.
>
> Thanks for persevering!  :-)
>
Marius Bakke May 30, 2020, 1:12 p.m. UTC | #8
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

> If those are the particular expectations and standards, should they change
> from only policy in the manual to something enforced by a git pre-commit
> hook?

That's a good idea.  I'm not sure about enforcing, but we could have a
post-commit hook that complains if all the files are not mentioned in
the commit message.
Anadon May 30, 2020, 4:49 p.m. UTC | #9
It could also enforce a number of linting details.  That'd save reviewers
time.

On Sat, May 30, 2020, 09:12 Marius Bakke <marius@gnu.org> wrote:

> Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:
>
> > If those are the particular expectations and standards, should they
> change
> > from only policy in the manual to something enforced by a git pre-commit
> > hook?
>
> That's a good idea.  I'm not sure about enforcing, but we could have a
> post-commit hook that complains if all the files are not mentioned in
> the commit message.
>
diff mbox series

Patch

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e6208ab3d9..fc451e83ef 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1365,14 +1365,14 @@  I/O-free core, and integration modules for
different event loops.")
 (define-public python-argon2-cffi
   (package
     (name "python-argon2-cffi")
-    (version "19.2.0")
+    (version "20.1.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "argon2-cffi" version))
         (sha256
          (base32
-          "18xxfw30gi3lwaz4vwb05iavzlrk3fa1x9fippzrgd3px8z65apz"))
+          "0zgr4mnnm0p4i99023safb0qb8cgvl202nly1rvylk2b7qnrn0nq"))
         (modules '((guix build utils)))
         (snippet '(begin (delete-file-recursively "extras") #t))))