diff mbox series

[bug#41067] Add python-pytest-asyncio

Message ID CAFkJGRdXz=GfarOjDM3c-rxyNkei7_taM=0iLEgGdhcC279t1A@mail.gmail.com
State Accepted
Headers show
Series [bug#41067] Add python-pytest-asyncio | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Anadon May 3, 2020, 11:06 p.m. UTC
Here's an addition for the python-pytest-asyncio package.  I'm not sure how
to merge the patches, but the two patches attached refer to the same
package.

Comments

Marius Bakke May 5, 2020, 6:01 p.m. UTC | #1
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

> Here's an addition for the python-pytest-asyncio package.  I'm not sure how
> to merge the patches, but the two patches attached refer to the same
> package.

Thanks!  You can use 'git commit --amend' to adjust the current commit.
For multiple commit there is 'git rebase --interactive HEAD~2' to open a
menu where you can "squash" the last two patches together.

Regardless, I've squashed the patches, fixed the indentation, added
double spacing and a little extra context in the description, and
finally provided a proper commit message.

Applied!
diff mbox series

Patch

From 66c95e2d01d194fd95d3a96e5fe513aa07b4a92f Mon Sep 17 00:00:00 2001
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
Date: Sun, 3 May 2020 18:22:23 -0400
Subject: [PATCH 1/2] Merged adding authors
To: guix-patches@gnu.org

---
 gnu/packages/check.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 427607e6de..eda33e283c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1408,6 +1409,32 @@  executed.")
 (define-public python2-coverage
   (package-with-python2 python-coverage))
 
+(define-public python-pytest-asyncio
+  (package
+    (name "python-pytest-asyncio")
+    (version "0.10.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pytest-asyncio" version))
+        (sha256
+          (base32 "1bysy4nii13bm7h345wxf8fxcjhab7l374pqdv7vwv3izl053b4z"))))
+  (build-system python-build-system)
+  (propagated-inputs
+   `(("python-pytest" ,python-pytest)))
+  (native-inputs
+   `(("python-coverage" ,python-coverage)
+     ("python-async-generator" ,python-async-generator)
+     ("python-hypothesis" ,python-hypothesis)))
+  (home-page "https://github.com/pytest-dev/pytest-asyncio")
+  (synopsis "Pytest support for asyncio.")
+  (description "Python asyncio code is usually written in the form of
+coroutines, which makes it slightly more difficult to test using normal
+testing tools. pytest-asyncio provides useful fixtures and markers to make
+testing easier.")
+  (license license:asl2.0)))
+
+
 (define-public python-cov-core
   (package
     (name "python-cov-core")
-- 
2.25.1